<!doctype html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Nunito%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic&amp;display=swap" /><link rel="profile" href="http://gmpg.org/xfn/11"><link media="all" href="https://theweedblog-com.exactdn.com/wp-content/cache/autoptimize/css/autoptimize_83d196c9e4d566f106752b104176b6ec.css" rel="stylesheet" /><title>Black Disabled Veteran sentenced to Five Years for Medical Marijuana</title><meta name="description" content="A disabled black veteran drove through Alabama with medical marijuana. Now he has been sentenced to five years in prison." /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://theweedblog.com/culture/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Black Disabled Veteran sentenced to Five Years for Medical Marijuana" /><meta property="og:description" content="A disabled black veteran drove through Alabama with medical marijuana. Now he has been sentenced to five years in prison." /><meta property="og:url" content="https://theweedblog.com/culture/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana" /><meta property="og:site_name" content="The Weed Blog" /><meta property="article:publisher" content="https://www.facebook.com/WeedBlog/" /><meta property="article:published_time" content="2020-07-15T20:32:32+00:00" /><meta property="article:modified_time" content="2020-07-15T20:41:15+00:00" /><meta property="og:image" content="https://theweedblog-com.exactdn.com/wp-content/uploads/prison-553836_1280.jpg?strip=all&#038;lossy=1&#038;ssl=1" /><meta property="og:image:width" content="1280" /><meta property="og:image:height" content="853" /><meta name="twitter:card" content="summary" /><meta name="twitter:creator" content="@TheWeedBlog" /><meta name="twitter:site" content="@TheWeedBlog" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://theweedblog.com/#website","url":"https://theweedblog.com/","name":"The Weed Blog","description":"Marijuana News And Information","potentialAction":[{"@type":"SearchAction","target":"https://theweedblog.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://theweedblog.com/culture/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana#primaryimage","inLanguage":"en-US","url":"https://theweedblog-com.exactdn.com/wp-content/uploads/prison-553836_1280.jpg?strip=all&lossy=1&ssl=1","width":1280,"height":853,"caption":"prison"},{"@type":"WebPage","@id":"https://theweedblog.com/culture/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana#webpage","url":"https://theweedblog.com/culture/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana","name":"Black Disabled Veteran sentenced to Five Years for Medical Marijuana","isPartOf":{"@id":"https://theweedblog.com/#website"},"primaryImageOfPage":{"@id":"https://theweedblog.com/culture/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana#primaryimage"},"datePublished":"2020-07-15T20:32:32+00:00","dateModified":"2020-07-15T20:41:15+00:00","author":{"@id":"https://theweedblog.com/#/schema/person/51ef0de60c19abb684e0100101159439"},"description":"A disabled black veteran drove through Alabama with medical marijuana. Now he has been sentenced to five years in prison.","breadcrumb":{"@id":"https://theweedblog.com/culture/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://theweedblog.com/culture/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana"]}]},{"@type":"BreadcrumbList","@id":"https://theweedblog.com/culture/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://theweedblog.com/","url":"https://theweedblog.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://theweedblog.com/culture","url":"https://theweedblog.com/culture","name":"Culture"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://theweedblog.com/culture/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana","url":"https://theweedblog.com/culture/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana","name":"Alabama Authorities Sentence Black Disabled Veteran to Five Years for Medical Marijuana"}}]},{"@type":["Person"],"@id":"https://theweedblog.com/#/schema/person/51ef0de60c19abb684e0100101159439","name":"Moira Feeney","image":{"@type":"ImageObject","@id":"https://theweedblog.com/#personlogo","inLanguage":"en-US","url":"https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg","caption":"Moira Feeney"},"description":"Moira Feeney has worked as a journalist in Latin America, Europe and the United States, reporting on politics, foreign policy and human rights issues. Writing about cannabis, according to Feeney, combines all three."}]}</script> <link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//theweedblog-com.exactdn.com' /><link href='https://theweedblog-com.exactdn.com' rel='preconnect' /><link href='https://www.googletagmanager.com' rel='preconnect' /><link href='https://www.google-analytics.com' rel='preconnect' /><link href='https://connect.facebook.net' rel='preconnect' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://www.facebook.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="The Weed Blog &raquo; Feed" href="https://theweedblog.com/feed" /><link rel="alternate" type="application/rss+xml" title="The Weed Blog &raquo; Comments Feed" href="https://theweedblog.com/comments/feed" /><link rel="alternate" type="application/rss+xml" title="The Weed Blog &raquo; Alabama Authorities Sentence Black Disabled Veteran to Five Years for Medical Marijuana Comments Feed" href="https://theweedblog.com/culture/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana/feed" /><style id='elementor-frontend-inline-css' type='text/css'>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</style> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-12477706-2'></script> <script type='text/javascript'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-12477706-2', {"anonymize_ip":true} );</script> <script type='text/javascript'>var eio_lazy_vars = {"exactdn_domain":"theweedblog-com.exactdn.com","skip_autoscale":"0"};</script> <link rel='https://api.w.org/' href='https://theweedblog.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theweedblog.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://theweedblog-com.exactdn.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://theweedblog.com/?p=60504' /><link rel="alternate" type="application/json+oembed" href="https://theweedblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheweedblog.com%2Fculture%2Falabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana" /><link rel="alternate" type="text/xml+oembed" href="https://theweedblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheweedblog.com%2Fculture%2Falabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.10.0" /><noscript><style>.lazyload[data-src]{display:none !important;}</style></noscript><link rel="icon" href="https://theweedblog-com.exactdn.com/wp-content/uploads/cropped-weedblogminilogo.png?strip=all&#038;lossy=1&#038;resize=32%2C32&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://theweedblog-com.exactdn.com/wp-content/uploads/cropped-weedblogminilogo.png?strip=all&#038;lossy=1&#038;resize=192%2C192&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://theweedblog-com.exactdn.com/wp-content/uploads/cropped-weedblogminilogo.png?strip=all&#038;lossy=1&#038;resize=180%2C180&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://theweedblog-com.exactdn.com/wp-content/uploads/cropped-weedblogminilogo.png?strip=all&#038;lossy=1&#038;resize=270%2C270&#038;ssl=1" />  <script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
				n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
				n.push=n;n.loaded=!0;n.version='2.0';n.agent='dvpixelcaffeinewordpress';n.queue=[];t=b.createElement(e);t.async=!0;
				t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
				document,'script','https://connect.facebook.net/en_US/fbevents.js');
			
			var aepc_pixel = {"pixel_id":"546009932779707","user":{},"enable_advanced_events":"yes","fire_delay":"0"},
				aepc_pixel_args = {},
				aepc_extend_args = function( args ) {
					if ( typeof args === 'undefined' ) {
						args = {};
					}

					for(var key in aepc_pixel_args)
						args[key] = aepc_pixel_args[key];

					return args;
				};

			// Extend args
			if ( 'yes' === aepc_pixel.enable_advanced_events ) {
				aepc_pixel_args.language = navigator.language;

				if ( document.referrer.indexOf( document.domain ) < 0 ) {
					aepc_pixel_args.referrer = document.referrer;
				}
			}

						fbq('init', '546009932779707', aepc_pixel.user);

						setTimeout( function() {
				fbq('track', "PageView", aepc_pixel_args);
			}, aepc_pixel.fire_delay * 1000 );</script> <noscript><img height="1" width="1" style="display:none"
 src="https://www.facebook.com/tr?id=546009932779707&ev=PageView&noscript=1"
 /></noscript></head><body class="post-template-default single single-post postid-60504 single-format-standard elementor-default elementor-kit-58018 elementor-page elementor-page-60504 elementor-page-58390"><div data-elementor-type="header" data-elementor-id="58019" class="elementor elementor-58019 elementor-location-header" data-elementor-settings="[]"><div class="elementor-inner"><div class="elementor-section-wrap"><section class="elementor-element elementor-element-1821c326 elementor-section-height-min-height elementor-section-boxed elementor-section-height-default elementor-section-items-middle elementor-section elementor-top-section" data-id="1821c326" data-element_type="section"><div class="elementor-container elementor-column-gap-no"><div class="elementor-row"><div class="elementor-element elementor-element-53352e28 elementor-column elementor-col-50 elementor-top-column" data-id="53352e28" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-6e8bea3b elementor-widget elementor-widget-image" data-id="6e8bea3b" data-element_type="widget" data-widget_type="image.default"><div class="elementor-widget-container"><div class="elementor-image"> <a href="https://theweedblog.com"> <img width="370" height="107" src="https://theweedblog-com.exactdn.com/wp-content/uploads/theweedblog-logo.png?strip=all&amp;lossy=1&amp;ssl=1&lazy=2" class="attachment-full size-full lazyload" alt=""   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/theweedblog-logo.png?strip=all&amp;lossy=1&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/theweedblog-logo.png?strip=all&amp;lossy=1&amp;ssl=1 370w, https://theweedblog-com.exactdn.com/wp-content/uploads/theweedblog-logo-300x87.png?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/theweedblog-logo.png?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w" data-sizes="auto" /><noscript><img width="370" height="107" src="https://theweedblog-com.exactdn.com/wp-content/uploads/theweedblog-logo.png?strip=all&amp;lossy=1&amp;ssl=1" class="attachment-full size-full" alt="" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/theweedblog-logo.png?strip=all&amp;lossy=1&amp;ssl=1 370w, https://theweedblog-com.exactdn.com/wp-content/uploads/theweedblog-logo-300x87.png?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/theweedblog-logo.png?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w" sizes="(max-width: 370px) 100vw, 370px" data-eio="l" /></noscript> </a></div></div></div></div></div></div><div class="elementor-element elementor-element-6b272540 elementor-column elementor-col-50 elementor-top-column" data-id="6b272540" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-6221cac elementor-shape-circle elementor-widget elementor-widget-social-icons" data-id="6221cac" data-element_type="widget" data-widget_type="social-icons.default"><div class="elementor-widget-container"><div class="elementor-social-icons-wrapper"> <a class="elementor-icon elementor-social-icon elementor-social-icon-facebook-f elementor-animation-grow elementor-repeater-item-4ab3639" href="https://www.facebook.com/WeedBlog" target="_blank"> <span class="elementor-screen-only">Facebook-f</span> <i class="fab fa-facebook-f"></i> </a> <a class="elementor-icon elementor-social-icon elementor-social-icon-twitter elementor-animation-grow elementor-repeater-item-c6cf71e" href="https://twitter.com/TheWeedBlog" target="_blank"> <span class="elementor-screen-only">Twitter</span> <i class="fab fa-twitter"></i> </a> <a class="elementor-icon elementor-social-icon elementor-social-icon-instagram elementor-animation-grow elementor-repeater-item-19d88b2" href="https://www.instagram.com/theweedblogdotcom" target="_blank"> <span class="elementor-screen-only">Instagram</span> <i class="fab fa-instagram"></i> </a> <a class="elementor-icon elementor-social-icon elementor-social-icon-pinterest elementor-animation-grow elementor-repeater-item-baa991c" href="https://pinterest.com/theweedblog" target="_blank"> <span class="elementor-screen-only">Pinterest</span> <i class="fab fa-pinterest"></i> </a></div></div></div></div></div></div></div></div></section><section class="elementor-element elementor-element-5d92d5a1 elementor-section-height-min-height elementor-section-boxed elementor-section-height-default elementor-section-items-middle elementor-section elementor-top-section" data-id="5d92d5a1" data-element_type="section" data-settings="{&quot;background_background&quot;:&quot;classic&quot;,&quot;sticky&quot;:&quot;top&quot;,&quot;sticky_on&quot;:[&quot;desktop&quot;,&quot;tablet&quot;,&quot;mobile&quot;],&quot;sticky_offset&quot;:0,&quot;sticky_effects_offset&quot;:0}"><div class="elementor-container elementor-column-gap-default"><div class="elementor-row"><div class="elementor-element elementor-element-5270bf8d elementor-column elementor-col-50 elementor-top-column" data-id="5270bf8d" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-7f382175 elementor-nav-menu__align-left elementor-nav-menu--stretch elementor-nav-menu--indicator-classic elementor-nav-menu--dropdown-tablet elementor-nav-menu__text-align-aside elementor-nav-menu--toggle elementor-nav-menu--burger elementor-widget elementor-widget-nav-menu" data-id="7f382175" data-element_type="widget" data-settings="{&quot;full_width&quot;:&quot;stretch&quot;,&quot;layout&quot;:&quot;horizontal&quot;,&quot;toggle&quot;:&quot;burger&quot;}" data-widget_type="nav-menu.default"><div class="elementor-widget-container"><nav role="navigation" class="elementor-nav-menu--main elementor-nav-menu__container elementor-nav-menu--layout-horizontal e--pointer-background e--animation-fade"><ul id="menu-1-7f382175" class="elementor-nav-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-58369"><a href="https://theweedblog.com/" class="elementor-item"><i class="fas fa-home"></i></a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58031"><a href="https://theweedblog.com/advocacy" class="elementor-item">Advocacy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58025"><a href="https://theweedblog.com/cooking" class="elementor-item">Cooking</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-58136"><a href="https://theweedblog.com/culture" class="elementor-item">Culture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58137"><a href="https://theweedblog.com/events" class="elementor-item">Events</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58029"><a href="https://theweedblog.com/growing" class="elementor-item">Growing</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58028"><a href="https://theweedblog.com/industry" class="elementor-item">Industry</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-58135"><a href="https://theweedblog.com/medical" class="elementor-item">Medical</a><ul class="sub-menu elementor-nav-menu--dropdown"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59697"><a href="/tag/missouri-medical-marijuana-program" class="elementor-sub-item">Missouri Medical Marijuana Program</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58034"><a href="https://theweedblog.com/policies" class="elementor-item">Policy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58026"><a href="https://theweedblog.com/science" class="elementor-item">Science</a></li></ul></nav><div class="elementor-menu-toggle" role="button" tabindex="0" aria-label="Menu Toggle" aria-expanded="false"> <i class="eicon-menu-bar" aria-hidden="true"></i> <span class="elementor-screen-only">Menu</span></div><nav class="elementor-nav-menu--dropdown elementor-nav-menu__container" role="navigation" aria-hidden="true"><ul id="menu-2-7f382175" class="elementor-nav-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-58369"><a href="https://theweedblog.com/" class="elementor-item"><i class="fas fa-home"></i></a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58031"><a href="https://theweedblog.com/advocacy" class="elementor-item">Advocacy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58025"><a href="https://theweedblog.com/cooking" class="elementor-item">Cooking</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-58136"><a href="https://theweedblog.com/culture" class="elementor-item">Culture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58137"><a href="https://theweedblog.com/events" class="elementor-item">Events</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58029"><a href="https://theweedblog.com/growing" class="elementor-item">Growing</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58028"><a href="https://theweedblog.com/industry" class="elementor-item">Industry</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-58135"><a href="https://theweedblog.com/medical" class="elementor-item">Medical</a><ul class="sub-menu elementor-nav-menu--dropdown"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59697"><a href="/tag/missouri-medical-marijuana-program" class="elementor-sub-item">Missouri Medical Marijuana Program</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58034"><a href="https://theweedblog.com/policies" class="elementor-item">Policy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58026"><a href="https://theweedblog.com/science" class="elementor-item">Science</a></li></ul></nav></div></div></div></div></div><div class="elementor-element elementor-element-d0a3f55 elementor-column elementor-col-50 elementor-top-column" data-id="d0a3f55" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-423785c elementor-search-form--skin-full_screen elementor-widget elementor-widget-search-form" data-id="423785c" data-element_type="widget" data-settings="{&quot;skin&quot;:&quot;full_screen&quot;}" data-widget_type="search-form.default"><div class="elementor-widget-container"><form class="elementor-search-form" role="search" action="https://theweedblog.com" method="get"><div class="elementor-search-form__toggle"> <i aria-hidden="true" class="fas fa-search"></i> <span class="elementor-screen-only">Search</span></div><div class="elementor-search-form__container"> <input placeholder="" class="elementor-search-form__input" type="search" name="s" title="Search" value=""><div class="dialog-lightbox-close-button dialog-close-button"> <i class="eicon-close" aria-hidden="true"></i> <span class="elementor-screen-only">Close</span></div></div></form></div></div></div></div></div></div></div></section></div></div></div><div data-elementor-type="single" data-elementor-id="58390" class="elementor elementor-58390 elementor-location-single post-60504 post type-post status-publish format-standard has-post-thumbnail hentry category-culture" data-elementor-settings="[]"><div class="elementor-inner"><div class="elementor-section-wrap"><section class="elementor-element elementor-element-666b9cb5 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="666b9cb5" data-element_type="section" data-settings="{&quot;background_background&quot;:&quot;classic&quot;}"><div class="elementor-container elementor-column-gap-no"><div class="elementor-row"><div class="elementor-element elementor-element-2841a441 elementor-column elementor-col-100 elementor-top-column" data-id="2841a441" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><section class="elementor-element elementor-element-4103cd2 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-inner-section" data-id="4103cd2" data-element_type="section"><div class="elementor-container elementor-column-gap-no"><div class="elementor-row"><div class="elementor-element elementor-element-c6ae601 elementor-column elementor-col-100 elementor-inner-column" data-id="c6ae601" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-5d801d3 elementor-widget-divider--view-line_text elementor-hidden-phone elementor-widget-divider--element-align-center elementor-widget elementor-widget-divider" data-id="5d801d3" data-element_type="widget" data-widget_type="divider.default"><div class="elementor-widget-container"><div class="elementor-divider"> <span class="elementor-divider-separator"> <span class="elementor-divider__text elementor-divider__element">July 15, 2020</span> </span></div></div></div><div class="elementor-element elementor-element-caf4e05 elementor-widget elementor-widget-heading" data-id="caf4e05" data-element_type="widget" data-widget_type="heading.default"><div class="elementor-widget-container"><h1 class="elementor-heading-title elementor-size-default">Alabama Authorities Sentence Black Disabled Veteran to Five Years for Medical Marijuana</h1></div></div><div class="elementor-element elementor-element-ec21c1d elementor-widget-divider--view-line_text elementor-widget__width-auto elementor-hidden-desktop elementor-hidden-tablet elementor-widget-divider--element-align-center elementor-widget elementor-widget-divider" data-id="ec21c1d" data-element_type="widget" data-widget_type="divider.default"><div class="elementor-widget-container"><div class="elementor-divider"> <span class="elementor-divider-separator"> <span class="elementor-divider__text elementor-divider__element">July 15, 2020</span> </span></div></div></div></div></div></div></div></div></section><div class="elementor-element elementor-element-a4bf99d elementor-align-left elementor-mobile-align-center elementor-widget elementor-widget-post-info" data-id="a4bf99d" data-element_type="widget" data-widget_type="post-info.default"><div class="elementor-widget-container"><ul class="elementor-inline-items elementor-icon-list-items elementor-post-info"><li class="elementor-icon-list-item elementor-repeater-item-fad6432 elementor-inline-item" itemprop="author"> <a href="https://theweedblog.com/author/moira-feeney"> <span class="elementor-icon-list-icon"> <img class="elementor-avatar lazyload" src="https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg?strip=all&lossy=1&ssl=1&lazy=2" alt="Moira Feeney" data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg?strip=all&lossy=1&ssl=1" loading="lazy"><noscript><img class="elementor-avatar" src="https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg?strip=all&lossy=1&ssl=1" alt="Moira Feeney" data-eio="l"></noscript> </span> <span class="elementor-icon-list-text elementor-post-info__item elementor-post-info__item--type-author"> Moira Feeney </span> </a></li><li class="elementor-icon-list-item elementor-repeater-item-d4a8ccc elementor-inline-item" itemprop="commentCount"> <a href="https://theweedblog.com/culture/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana#disqus_thread"> <span class="elementor-icon-list-icon"> <i aria-hidden="true" class="far fa-comments"></i> </span> <span class="elementor-icon-list-text elementor-post-info__item elementor-post-info__item--type-comments"> View Comments </span> </a></li></ul></div></div></div></div></div></div></div></section><section class="elementor-element elementor-element-1aba6fa5 elementor-section-full_width elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="1aba6fa5" data-element_type="section"><div class="elementor-container elementor-column-gap-default"><div class="elementor-row"><div class="elementor-element elementor-element-5f49b629 elementor-column elementor-col-100 elementor-top-column" data-id="5f49b629" data-element_type="column" data-settings="{&quot;background_background&quot;:&quot;classic&quot;}"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-85f702b elementor-widget elementor-widget-theme-post-featured-image elementor-widget-image" data-id="85f702b" data-element_type="widget" data-widget_type="theme-post-featured-image.default"><div class="elementor-widget-container"><div class="elementor-image"> <img src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-1280x533.png" title="prison-553836_1280" alt="prison" data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/prison-553836_1280.jpg?strip=all&amp;lossy=1&amp;resize=1280%2C533&amp;ssl=1" loading="lazy" class="lazyload" /><noscript><img src="https://theweedblog-com.exactdn.com/wp-content/uploads/prison-553836_1280.jpg?strip=all&amp;lossy=1&amp;resize=1280%2C533&amp;ssl=1" title="prison-553836_1280" alt="prison" data-eio="l" /></noscript></div></div></div></div></div></div></div></div></section><section class="elementor-element elementor-element-47a4a0c2 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="47a4a0c2" data-element_type="section" data-settings="{&quot;background_background&quot;:&quot;classic&quot;}"><div class="elementor-container elementor-column-gap-no"><div class="elementor-row"><div class="elementor-element elementor-element-18174b12 elementor-column elementor-col-100 elementor-top-column" data-id="18174b12" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><section class="elementor-element elementor-element-abd852e elementor-section-full_width elementor-section-height-default elementor-section-height-default elementor-section elementor-inner-section" data-id="abd852e" data-element_type="section"><div class="elementor-container elementor-column-gap-no"><div class="elementor-row"><div class="elementor-element elementor-element-0da084d elementor-column elementor-col-100 elementor-inner-column" data-id="0da084d" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-3a205d95 article-content elementor-widget elementor-widget-theme-post-content" data-id="3a205d95" data-element_type="widget" data-widget_type="theme-post-content.default"><div class="elementor-widget-container"><p>It was August 2016 when U.S. military veteran Sean Worsley and his wife Eboni were on a road trip to visit each of their parents. They’d stopped to buy gas in a small Alabama town when a local cop approached and told them their music was too loud and that he wanted to search their car. He said he smelled marijuana, which was probably not true unless the officer had canine-level olfactory abilities.</p><h2>Sean Worsley had Legal Medical Marijuana</h2><p>Worsley’s legally prescribed medical marijuana was stored properly among his belongings in the backseat. However, his Arizona-issued MMJ recommendation was <em>not</em> legal in Alabama, a fact he was unaware of.</p><p>Now, four years years later, Sean Worsley<a href="https://www.alreporter.com/2020/07/13/black-disabled-veteran-sentenced-to-spend-60-months-in-prison-for-medical-marijuana/"> has been sentenced</a> to 60 months in an Alabama prison…for legal medical marijuana.</p><p>How did this happen?</p><p>Worsley, a disabled Black veteran who earned a Purple Heart for five years of service in the military including a 14-month deployment to Iraq, agreed to the car search. Big mistake.</p><p>As expected, police officer Carl Abramo of Gordo Alabama found the MMJ, called for backup, then cuffed and arrested Worsley <em>and</em> his wife Eboni.</p><p>Eboni’s crime? Her own prescription medication (not MMJ) wasn’t in its original bottle, which Abramo said constituted a felony, with which she was charged.</p><p>Their years-long nightmare begins.</p><p>The arrest drove the Worsleys into homelessness, joblessness, rendered them penniless, owing thousands of dollars in court costs, fines, lawyers’ fees and travel expenses.</p><p>“I feel like I’m being thrown away by a country I went and served for,” Worsley wrote in a letter from the Pickens County Jail to<a href="https://www.alabamaappleseed.org/"> Alabama Appleseed,</a> a criminal justice organization that recently published a <a href="https://www.alabamaappleseed.org/marijuana-reform/thrown-away/">detailed account</a> of Worsley’s case.</p><p>“I feel like I lost parts of me in Iraq, parts of my spirit and soul that I can’t ever get back.”&nbsp;</p><p>Sean, now 33, had been using MMJ to treat a traumatic brain injury and post-traumatic stress disorder (PTSD) from his deployment in Iraq as well as to calm his nightmares and soothe chronic back pain.</p><p>Eboni, according to Appleseed, said that when they got to court, she and Sean were taken to separate rooms where she attempted to explain that her husband was disabled with serious cognitive issues and needed a guardian to help him understand the process and ensure he made an informed decision.</p><p>The authorities didn’t seem to care and managed to get Sean to accept a plea and a five-year prison sentence.</p></div></div></div></div></div></div></div></section><section class="elementor-element elementor-element-3ae4c5f elementor-section-full_width elementor-section-height-default elementor-section-height-default elementor-section elementor-inner-section" data-id="3ae4c5f" data-element_type="section"><div class="elementor-container elementor-column-gap-no"><div class="elementor-row"><div class="elementor-element elementor-element-d38428e elementor-column elementor-col-100 elementor-inner-column" data-id="d38428e" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-babd506 elementor-align-left elementor-widget-tablet__width-inherit elementor-widget elementor-widget-post-info" data-id="babd506" data-element_type="widget" data-widget_type="post-info.default"><div class="elementor-widget-container"><ul class="elementor-inline-items elementor-icon-list-items elementor-post-info"><li class="elementor-icon-list-item elementor-repeater-item-67fa431 elementor-inline-item"> <span class="elementor-icon-list-icon"> <i aria-hidden="true" class="fas fa-calendar"></i> </span> <span class="elementor-icon-list-text elementor-post-info__item elementor-post-info__item--type-custom"> Last Modified: July 15, 2020 </span></li></ul></div></div><div class="elementor-element elementor-element-4f14389 elementor-align-left elementor-widget elementor-widget-post-info" data-id="4f14389" data-element_type="widget" data-widget_type="post-info.default"><div class="elementor-widget-container"><ul class="elementor-inline-items elementor-icon-list-items elementor-post-info"><li class="elementor-icon-list-item elementor-repeater-item-5b276ce elementor-inline-item" itemprop="about"> <span class="elementor-icon-list-text elementor-post-info__item elementor-post-info__item--type-terms"> <span class="elementor-post-info__item-prefix">Category:</span> <span class="elementor-post-info__terms-list"> <a href="https://theweedblog.com/culture" class="elementor-post-info__terms-list-item">Culture</a> </span> </span></li></ul></div></div></div></div></div></div></div></section><section class="elementor-element elementor-element-2b8d7ee elementor-section-full_width elementor-section-height-default elementor-section-height-default elementor-section elementor-inner-section" data-id="2b8d7ee" data-element_type="section"><div class="elementor-container elementor-column-gap-no"><div class="elementor-row"><div class="elementor-element elementor-element-a65a834 elementor-column elementor-col-100 elementor-inner-column" data-id="a65a834" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-4c3ab473 elementor-widget__width-auto elementor-widget-mobile__width-inherit elementor-widget elementor-widget-heading" data-id="4c3ab473" data-element_type="widget" data-widget_type="heading.default"><div class="elementor-widget-container"><h2 class="elementor-heading-title elementor-size-default">Share:</h2></div></div><div class="elementor-element elementor-element-650828ae elementor-share-buttons--skin-flat elementor-share-buttons--align-left elementor-share-buttons-mobile--align-center elementor-widget__width-auto elementor-share-buttons--shape-circle elementor-grid-mobile-2 elementor-share-buttons--view-icon-text elementor-grid-0 elementor-share-buttons--color-official elementor-widget elementor-widget-share-buttons" data-id="650828ae" data-element_type="widget" data-widget_type="share-buttons.default"><div class="elementor-widget-container"><div class="elementor-grid"><div class="elementor-grid-item"><div class="elementor-share-btn elementor-share-btn_facebook"> <span class="elementor-share-btn__icon"> <i class="fab fa-facebook" aria-hidden="true"></i> <span class="elementor-screen-only">Share on facebook</span> </span><div class="elementor-share-btn__text"> <span class="elementor-share-btn__title"> Facebook </span></div></div></div><div class="elementor-grid-item"><div class="elementor-share-btn elementor-share-btn_twitter"> <span class="elementor-share-btn__icon"> <i class="fab fa-twitter" aria-hidden="true"></i> <span class="elementor-screen-only">Share on twitter</span> </span><div class="elementor-share-btn__text"> <span class="elementor-share-btn__title"> Twitter </span></div></div></div><div class="elementor-grid-item"><div class="elementor-share-btn elementor-share-btn_pinterest"> <span class="elementor-share-btn__icon"> <i class="fab fa-pinterest" aria-hidden="true"></i> <span class="elementor-screen-only">Share on pinterest</span> </span><div class="elementor-share-btn__text"> <span class="elementor-share-btn__title"> Pinterest </span></div></div></div><div class="elementor-grid-item"><div class="elementor-share-btn elementor-share-btn_reddit"> <span class="elementor-share-btn__icon"> <i class="fab fa-reddit" aria-hidden="true"></i> <span class="elementor-screen-only">Share on reddit</span> </span><div class="elementor-share-btn__text"> <span class="elementor-share-btn__title"> Reddit </span></div></div></div></div></div></div></div></div></div></div></div></section><div class="elementor-element elementor-element-7c39af46 elementor-author-box--layout-image-left elementor-author-box--align-left ignore-toc elementor-author-box--link-yes elementor-author-box--avatar-yes elementor-author-box--name-yes elementor-author-box--biography-yes elementor-widget elementor-widget-author-box" data-id="7c39af46" data-element_type="widget" data-widget_type="author-box.default"><div class="elementor-widget-container"><div class="elementor-author-box"><div  class="elementor-author-box__avatar"> <img src="https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg?strip=all&lossy=1&ssl=1&lazy=2" alt="Moira Feeney" data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg?strip=all&lossy=1&ssl=1" loading="lazy" class="lazyload"><noscript><img src="https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg?strip=all&lossy=1&ssl=1" alt="Moira Feeney" data-eio="l"></noscript></div><div class="elementor-author-box__text"><div ><h4 class="elementor-author-box__name">Moira Feeney</h4></div><div class="elementor-author-box__bio"> Moira Feeney has worked as a journalist in Latin America, Europe and the United States, reporting on politics, foreign policy and human rights issues. Writing about cannabis, according to Feeney, combines all three.</div> <a class="elementor-author-box__button elementor-button elementor-size-xs" href="https://theweedblog.com/author/moira-feeney"> View Author's Articles </a></div></div></div></div><div class="elementor-element elementor-element-317f518 elementor-widget elementor-widget-shortcode" data-id="317f518" data-element_type="widget" data-widget_type="shortcode.default"><div class="elementor-widget-container"><div class="elementor-shortcode"><div id="disqus_thread"><div id="dcl_btn_container"> <button id='dcl_comment_btn' class=""> Load Comments </button></div></div></div></div></div></div></div></div></div></div></section><section class="elementor-element elementor-element-cbb4973 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="cbb4973" data-element_type="section" data-settings="{&quot;background_background&quot;:&quot;classic&quot;}"><div class="elementor-container elementor-column-gap-no"><div class="elementor-row"><div class="elementor-element elementor-element-fe5f3b0 elementor-column elementor-col-100 elementor-top-column" data-id="fe5f3b0" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><section class="elementor-element elementor-element-9485c3e elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-inner-section" data-id="9485c3e" data-element_type="section"><div class="elementor-container elementor-column-gap-no"><div class="elementor-row"><div class="elementor-element elementor-element-a569a52 elementor-column elementor-col-100 elementor-inner-column" data-id="a569a52" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-dfe07d5 elementor-widget-divider--view-line_text elementor-hidden-phone elementor-widget-divider--element-align-center elementor-widget elementor-widget-divider" data-id="dfe07d5" data-element_type="widget" data-widget_type="divider.default"><div class="elementor-widget-container"><div class="elementor-divider"> <span class="elementor-divider-separator"> <span class="elementor-divider__text elementor-divider__element">Recent & Related Posts</span> </span></div></div></div><div class="elementor-element elementor-element-a622694 elementor-widget elementor-widget-heading" data-id="a622694" data-element_type="widget" data-widget_type="heading.default"><div class="elementor-widget-container"><h2 class="elementor-heading-title elementor-size-default"><a href="https://theweedblog.com/culture" rel="tag">Culture</a> Articles</h2></div></div><div class="elementor-element elementor-element-3c7b266 elementor-widget__width-auto elementor-align-right elementor-absolute elementor-hidden-tablet elementor-hidden-phone elementor-widget elementor-widget-button" data-id="3c7b266" data-element_type="widget" data-settings="{&quot;_position&quot;:&quot;absolute&quot;}" data-widget_type="button.default"><div class="elementor-widget-container"><div class="elementor-button-wrapper"> <a href="https://theweedblog.com/" class="elementor-button-link elementor-button elementor-size-sm" role="button"> <span class="elementor-button-content-wrapper"> <span class="elementor-button-icon elementor-align-icon-right"> <i aria-hidden="true" class="fas fa-chevron-right"></i> </span> <span class="elementor-button-text">Go Back Home</span> </span> </a></div></div></div><div class="elementor-element elementor-element-dc59cdf elementor-widget-divider--view-line_text elementor-widget__width-auto elementor-hidden-desktop elementor-hidden-tablet elementor-widget-divider--element-align-center elementor-widget elementor-widget-divider" data-id="dc59cdf" data-element_type="widget" data-widget_type="divider.default"><div class="elementor-widget-container"><div class="elementor-divider"> <span class="elementor-divider-separator"> <span class="elementor-divider__text elementor-divider__element">Recent & Related Posts</span> </span></div></div></div></div></div></div></div></div></section><section class="elementor-element elementor-element-755a160 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-inner-section" data-id="755a160" data-element_type="section"><div class="elementor-container elementor-column-gap-no"><div class="elementor-row"><div class="elementor-element elementor-element-9aefc41 elementor-column elementor-col-100 elementor-inner-column" data-id="9aefc41" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-fe696c0 elementor-grid-3 elementor-grid-tablet-2 elementor-grid-mobile-1 elementor-posts--thumbnail-top elementor-posts--show-avatar elementor-card-shadow-yes elementor-posts__hover-gradient elementor-widget elementor-widget-posts" data-id="fe696c0" data-element_type="widget" data-settings="{&quot;cards_columns&quot;:&quot;3&quot;,&quot;cards_columns_tablet&quot;:&quot;2&quot;,&quot;cards_columns_mobile&quot;:&quot;1&quot;,&quot;cards_row_gap&quot;:{&quot;unit&quot;:&quot;px&quot;,&quot;size&quot;:35,&quot;sizes&quot;:[]}}" data-widget_type="posts.cards"><div class="elementor-widget-container"><div class="elementor-posts-container elementor-posts elementor-posts--skin-cards elementor-grid"><article class="elementor-post elementor-grid-item post-60343 post type-post status-publish format-standard has-post-thumbnail hentry category-culture tag-anti-marijuana-psa tag-driving tag-psa tag-stoned-driving"><div class="elementor-post__card"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/culture/driving-while-high-psa" ><div class="elementor-post__thumbnail"><img width="300" height="300" src="https://theweedblog-com.exactdn.com/wp-content/uploads/driving-marijuana-dui-duii.jpg?strip=all&lossy=1&ssl=1&lazy=2" class="attachment-medium_large size-medium_large lazyload" alt="driving marijuana dui duii"   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/driving-marijuana-dui-duii.jpg?strip=all&lossy=1&ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/driving-marijuana-dui-duii.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/driving-marijuana-dui-duii-150x150.jpg?strip=all&amp;lossy=1&amp;ssl=1 150w, https://theweedblog-com.exactdn.com/wp-content/uploads/driving-marijuana-dui-duii-250x250.jpg?strip=all&amp;lossy=1&amp;ssl=1 250w" data-sizes="auto" /><noscript><img width="300" height="300" src="https://theweedblog-com.exactdn.com/wp-content/uploads/driving-marijuana-dui-duii.jpg?strip=all&lossy=1&ssl=1" class="attachment-medium_large size-medium_large" alt="driving marijuana dui duii" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/driving-marijuana-dui-duii.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/driving-marijuana-dui-duii-150x150.jpg?strip=all&amp;lossy=1&amp;ssl=1 150w, https://theweedblog-com.exactdn.com/wp-content/uploads/driving-marijuana-dui-duii-250x250.jpg?strip=all&amp;lossy=1&amp;ssl=1 250w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__badge">Culture</div><div class="elementor-post__avatar"> <img src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-128x128.png" width="128" height="128" alt="Moira Feeney" class="avatar avatar-128 wp-user-avatar wp-user-avatar-128 alignnone photo lazyload" data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg?strip=all&lossy=1&resize=128%2C128&ssl=1" loading="lazy" /><noscript><img src="https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg?strip=all&lossy=1&resize=128%2C128&ssl=1" width="128" height="128" alt="Moira Feeney" class="avatar avatar-128 wp-user-avatar wp-user-avatar-128 alignnone photo" data-eio="l" /></noscript></div><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/culture/driving-while-high-psa" > Driving While High PSA Straight out of Reefer Madness Hits the Airwaves </a></h3><div class="elementor-post__excerpt"><p>Like we don’t already have enough on our minds with the coronavirus pandemic surging, the economy collapsing and keeping up with a massive. legitimate and</p></div> <a class="elementor-post__read-more" href="https://theweedblog.com/culture/driving-while-high-psa" > Read More » </a></div><div class="elementor-post__meta-data"> <span class="elementor-post-date"> July 8, 2020 </span> <span class="elementor-post-avatar"> <span class="dsq-postid" data-dsqidentifier="60343 https://theweedblog.com/?p=60343">No Comments</span> </span></div></div></article><article class="elementor-post elementor-grid-item post-60317 post type-post status-publish format-standard has-post-thumbnail hentry category-culture tag-cannabis-and-health tag-senior-citizens tag-seniors tag-seniors-and-cannabis"><div class="elementor-post__card"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/culture/senior-cannabis-consumers-more-active-lower-bmi" ><div class="elementor-post__thumbnail"><img width="768" height="576" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-768x576.png" class="attachment-medium_large size-medium_large lazyload" alt="Seniors and Cannabis"   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-768x576.jpg?strip=all&lossy=1&ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-768x576.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-300x225.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-1024x768.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-1536x1152.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-2048x1536.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" data-sizes="auto" /><noscript><img width="768" height="576" src="https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-768x576.jpg?strip=all&lossy=1&ssl=1" class="attachment-medium_large size-medium_large" alt="Seniors and Cannabis" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-768x576.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-300x225.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-1024x768.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-1536x1152.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-2048x1536.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/james-hose-jr-6D58t6uZT5M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" sizes="(max-width: 768px) 100vw, 768px" data-eio="l" /></noscript></div> </a><div class="elementor-post__badge">Culture</div><div class="elementor-post__avatar"> <img src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-128x128.png" width="128" height="128" alt="Moira Feeney" class="avatar avatar-128 wp-user-avatar wp-user-avatar-128 alignnone photo lazyload" data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg?strip=all&lossy=1&resize=128%2C128&ssl=1" loading="lazy" /><noscript><img src="https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg?strip=all&lossy=1&resize=128%2C128&ssl=1" width="128" height="128" alt="Moira Feeney" class="avatar avatar-128 wp-user-avatar wp-user-avatar-128 alignnone photo" data-eio="l" /></noscript></div><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/culture/senior-cannabis-consumers-more-active-lower-bmi" > Senior Cannabis Consumers More Active and Have Lower BMI </a></h3><div class="elementor-post__excerpt"><p>A new study concluded that older Americans who consumed cannabis were more inclined to participate in group exercise and challenging physical activity than their non-consuming</p></div> <a class="elementor-post__read-more" href="https://theweedblog.com/culture/senior-cannabis-consumers-more-active-lower-bmi" > Read More » </a></div><div class="elementor-post__meta-data"> <span class="elementor-post-date"> July 6, 2020 </span> <span class="elementor-post-avatar"> <span class="dsq-postid" data-dsqidentifier="60317 https://theweedblog.com/?p=60317">No Comments</span> </span></div></div></article><article class="elementor-post elementor-grid-item post-60304 post type-post status-publish format-standard has-post-thumbnail hentry category-culture tag-cbd tag-july-4th tag-pets"><div class="elementor-post__card"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/culture/cbd-can-help-pets-july-4th-fireworks" ><div class="elementor-post__thumbnail"><img width="768" height="512" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-768x512.png" class="attachment-medium_large size-medium_large lazyload" alt="fireworks"   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-768x512.jpg?strip=all&lossy=1&ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-768x512.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-1024x683.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-1536x1024.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-2048x1365.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" data-sizes="auto" /><noscript><img width="768" height="512" src="https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-768x512.jpg?strip=all&lossy=1&ssl=1" class="attachment-medium_large size-medium_large" alt="fireworks" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-768x512.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-1024x683.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-1536x1024.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-2048x1365.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/sharosh-rajasekher-BIR-C7RSNzI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" sizes="(max-width: 768px) 100vw, 768px" data-eio="l" /></noscript></div> </a><div class="elementor-post__badge">Culture</div><div class="elementor-post__avatar"> <img src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-128x128.png" width="128" height="128" alt="Moira Feeney" class="avatar avatar-128 wp-user-avatar wp-user-avatar-128 alignnone photo lazyload" data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg?strip=all&lossy=1&resize=128%2C128&ssl=1" loading="lazy" /><noscript><img src="https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg?strip=all&lossy=1&resize=128%2C128&ssl=1" width="128" height="128" alt="Moira Feeney" class="avatar avatar-128 wp-user-avatar wp-user-avatar-128 alignnone photo" data-eio="l" /></noscript></div><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/culture/cbd-can-help-pets-july-4th-fireworks" > CBD Can Help Your Pets With July 4th Fireworks </a></h3><div class="elementor-post__excerpt"><p>With July 4th upon us and organized fireworks displays having been canceled in many cities and towns due to coronavirus concerns, it seems this year</p></div> <a class="elementor-post__read-more" href="https://theweedblog.com/culture/cbd-can-help-pets-july-4th-fireworks" > Read More » </a></div><div class="elementor-post__meta-data"> <span class="elementor-post-date"> July 3, 2020 </span> <span class="elementor-post-avatar"> <span class="dsq-postid" data-dsqidentifier="60304 https://theweedblog.com/?p=60304">No Comments</span> </span></div></div></article><article class="elementor-post elementor-grid-item post-60188 post type-post status-publish format-standard has-post-thumbnail hentry category-culture tag-lester-grinspoon tag-marijuana-legalization"><div class="elementor-post__card"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/culture/lester-grinspoon-intellectual-leader-marijuana-legalization-dies" ><div class="elementor-post__thumbnail"><img width="686" height="300" src="https://theweedblog-com.exactdn.com/wp-content/uploads/Dr-Lester-Grinspoon-1.jpg?strip=all&lossy=1&ssl=1&lazy=2" class="attachment-medium_large size-medium_large lazyload" alt="Dr. Lester Grinspoon"   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/Dr-Lester-Grinspoon-1.jpg?strip=all&lossy=1&ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/Dr-Lester-Grinspoon-1.jpg?strip=all&amp;lossy=1&amp;ssl=1 686w, https://theweedblog-com.exactdn.com/wp-content/uploads/Dr-Lester-Grinspoon-1-300x131.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/Dr-Lester-Grinspoon-1.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/Dr-Lester-Grinspoon-1.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w" data-sizes="auto" /><noscript><img width="686" height="300" src="https://theweedblog-com.exactdn.com/wp-content/uploads/Dr-Lester-Grinspoon-1.jpg?strip=all&lossy=1&ssl=1" class="attachment-medium_large size-medium_large" alt="Dr. Lester Grinspoon" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/Dr-Lester-Grinspoon-1.jpg?strip=all&amp;lossy=1&amp;ssl=1 686w, https://theweedblog-com.exactdn.com/wp-content/uploads/Dr-Lester-Grinspoon-1-300x131.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/Dr-Lester-Grinspoon-1.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/Dr-Lester-Grinspoon-1.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w" sizes="(max-width: 686px) 100vw, 686px" data-eio="l" /></noscript></div> </a><div class="elementor-post__badge">Culture</div><div class="elementor-post__avatar"> <img src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-128x128.png" width="128" height="128" alt="Moira Feeney" class="avatar avatar-128 wp-user-avatar wp-user-avatar-128 alignnone photo lazyload" data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg?strip=all&lossy=1&resize=128%2C128&ssl=1" loading="lazy" /><noscript><img src="https://theweedblog-com.exactdn.com/wp-content/uploads/moiras-photo.jpg?strip=all&lossy=1&resize=128%2C128&ssl=1" width="128" height="128" alt="Moira Feeney" class="avatar avatar-128 wp-user-avatar wp-user-avatar-128 alignnone photo" data-eio="l" /></noscript></div><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/culture/lester-grinspoon-intellectual-leader-marijuana-legalization-dies" > RIP Dr. Lester Grinspoon: Intellectual Leader of Marijuana Legalization Movement Dies at 92 </a></h3><div class="elementor-post__excerpt"><p>Dr. Lester Grinspoon celebrated his 92nd birthday on June 25 and passed away in the early morning of June 26, with his wife Betsy by</p></div> <a class="elementor-post__read-more" href="https://theweedblog.com/culture/lester-grinspoon-intellectual-leader-marijuana-legalization-dies" > Read More » </a></div><div class="elementor-post__meta-data"> <span class="elementor-post-date"> June 25, 2020 </span> <span class="elementor-post-avatar"> <span class="dsq-postid" data-dsqidentifier="60188 https://theweedblog.com/?p=60188">No Comments</span> </span></div></div></article><article class="elementor-post elementor-grid-item post-2428 post type-post status-publish format-standard has-post-thumbnail hentry category-culture tag-cannabis-culture tag-edibles"><div class="elementor-post__card"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/culture/edible-review-wana-brands-watermelon-sour-sativa-gummies" ><div class="elementor-post__thumbnail"><img width="768" height="549" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-768x549.png" class="attachment-medium_large size-medium_large lazyload" alt="wanna gummies"   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-768x549.jpg?strip=all&lossy=1&ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-768x549.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-300x214.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-1024x731.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-1536x1097.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-2048x1463.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" data-sizes="auto" /><noscript><img width="768" height="549" src="https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-768x549.jpg?strip=all&lossy=1&ssl=1" class="attachment-medium_large size-medium_large" alt="wanna gummies" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-768x549.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-300x214.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-1024x731.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-1536x1097.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-2048x1463.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/pharma-hemp-complex-45eGK42Vzwo-unsplash-4-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" sizes="(max-width: 768px) 100vw, 768px" data-eio="l" /></noscript></div> </a><div class="elementor-post__badge">Culture</div><div class="elementor-post__avatar"> <img src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-128x128.png" width="128" height="128" alt="Leah Maurer" class="avatar avatar-128 wp-user-avatar wp-user-avatar-128 alignnone photo lazyload" data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/leah-headshot.jpg?strip=all&lossy=1&resize=128%2C128&ssl=1" loading="lazy" /><noscript><img src="https://theweedblog-com.exactdn.com/wp-content/uploads/leah-headshot.jpg?strip=all&lossy=1&resize=128%2C128&ssl=1" width="128" height="128" alt="Leah Maurer" class="avatar avatar-128 wp-user-avatar wp-user-avatar-128 alignnone photo" data-eio="l" /></noscript></div><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/culture/edible-review-wana-brands-watermelon-sour-sativa-gummies" > Edible Review: Wana Brands Watermelon Sour Sativa Gummies </a></h3><div class="elementor-post__excerpt"><p>As legal medical and recreational cannabis markets expand, the industry is continually pursuing various ways to process and consume marijuana.&nbsp; Edibles have become one of</p></div> <a class="elementor-post__read-more" href="https://theweedblog.com/culture/edible-review-wana-brands-watermelon-sour-sativa-gummies" > Read More » </a></div><div class="elementor-post__meta-data"> <span class="elementor-post-date"> June 20, 2020 </span> <span class="elementor-post-avatar"> <span class="dsq-postid" data-dsqidentifier="2428 http://ci02427fe840032658">No Comments</span> </span></div></div></article><article class="elementor-post elementor-grid-item post-59940 post type-post status-publish format-standard has-post-thumbnail hentry category-culture category-medical tag-missouri tag-missouri-medical-marijuana-program tag-state-laws"><div class="elementor-post__card"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/culture/what-was-missouri-amendment-3" ><div class="elementor-post__thumbnail"><img width="768" height="512" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-768x512.png" class="attachment-medium_large size-medium_large lazyload" alt=""   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-768x512.jpg?strip=all&lossy=1&ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-768x512.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-1024x683.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-1536x1024.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-2048x1366.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" data-sizes="auto" /><noscript><img width="768" height="512" src="https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-768x512.jpg?strip=all&lossy=1&ssl=1" class="attachment-medium_large size-medium_large" alt="" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-768x512.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-1024x683.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-1536x1024.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-2048x1366.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/element5-digital-T9CXBZLUvic-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" sizes="(max-width: 768px) 100vw, 768px" data-eio="l" /></noscript></div> </a><div class="elementor-post__badge">Culture</div><div class="elementor-post__avatar"> <img src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-128x128.png" width="128" height="128" alt="John Payne" class="avatar avatar-128 wp-user-avatar wp-user-avatar-128 alignnone photo lazyload" data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/IMG_5711-e1591382337516.jpg?strip=all&lossy=1&resize=128%2C128&ssl=1" loading="lazy" /><noscript><img src="https://theweedblog-com.exactdn.com/wp-content/uploads/IMG_5711-e1591382337516.jpg?strip=all&lossy=1&resize=128%2C128&ssl=1" width="128" height="128" alt="John Payne" class="avatar avatar-128 wp-user-avatar wp-user-avatar-128 alignnone photo" data-eio="l" /></noscript></div><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/culture/what-was-missouri-amendment-3" > What Was Missouri Amendment 3? </a></h3><div class="elementor-post__excerpt"><p>Missouri amendment 3 was an initiative placed on Missouri’s November 2018 ballot, which would have amended the state constitution to legalize medical marijuana and fund</p></div> <a class="elementor-post__read-more" href="https://theweedblog.com/culture/what-was-missouri-amendment-3" > Read More » </a></div><div class="elementor-post__meta-data"> <span class="elementor-post-date"> June 17, 2020 </span> <span class="elementor-post-avatar"> <span class="dsq-postid" data-dsqidentifier="59940 https://theweedblog.com/?p=59940">No Comments</span> </span></div></div></article></div></div></div></div></div></div></div></div></section><section class="elementor-element elementor-element-a792f6f elementor-hidden-desktop elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-inner-section" data-id="a792f6f" data-element_type="section"><div class="elementor-container elementor-column-gap-default"><div class="elementor-row"><div class="elementor-element elementor-element-a8a9450 elementor-column elementor-col-100 elementor-inner-column" data-id="a8a9450" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-81f6053 elementor-widget__width-auto elementor-align-right elementor-widget elementor-widget-button" data-id="81f6053" data-element_type="widget" data-widget_type="button.default"><div class="elementor-widget-container"><div class="elementor-button-wrapper"> <a href="https://theweedblog.com/" class="elementor-button-link elementor-button elementor-size-sm" role="button"> <span class="elementor-button-content-wrapper"> <span class="elementor-button-icon elementor-align-icon-right"> <i aria-hidden="true" class="fas fa-chevron-right"></i> </span> <span class="elementor-button-text">Go Back Home</span> </span> </a></div></div></div></div></div></div></div></div></section></div></div></div></div></div></section></div></div></div><div data-elementor-type="footer" data-elementor-id="58336" class="elementor elementor-58336 elementor-location-footer" data-elementor-settings="[]"><div class="elementor-inner"><div class="elementor-section-wrap"><section class="elementor-element elementor-element-7de3fb0 elementor-section-height-min-height elementor-hidden-tablet elementor-hidden-phone elementor-section-boxed elementor-section-height-default elementor-section-items-middle elementor-section elementor-top-section" data-id="7de3fb0" data-element_type="section" data-settings="{&quot;background_background&quot;:&quot;classic&quot;}"><div class="elementor-container elementor-column-gap-default"><div class="elementor-row"><div class="elementor-element elementor-element-9c827a7 elementor-column elementor-col-100 elementor-top-column" data-id="9c827a7" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-9481b8d elementor-nav-menu__align-left elementor-nav-menu--stretch elementor-nav-menu--indicator-classic elementor-nav-menu--dropdown-tablet elementor-nav-menu__text-align-aside elementor-nav-menu--toggle elementor-nav-menu--burger elementor-widget elementor-widget-nav-menu" data-id="9481b8d" data-element_type="widget" data-settings="{&quot;full_width&quot;:&quot;stretch&quot;,&quot;layout&quot;:&quot;horizontal&quot;,&quot;toggle&quot;:&quot;burger&quot;}" data-widget_type="nav-menu.default"><div class="elementor-widget-container"><nav role="navigation" class="elementor-nav-menu--main elementor-nav-menu__container elementor-nav-menu--layout-horizontal e--pointer-background e--animation-fade"><ul id="menu-1-9481b8d" class="elementor-nav-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-58369"><a href="https://theweedblog.com/" class="elementor-item"><i class="fas fa-home"></i></a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58031"><a href="https://theweedblog.com/advocacy" class="elementor-item">Advocacy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58025"><a href="https://theweedblog.com/cooking" class="elementor-item">Cooking</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-58136"><a href="https://theweedblog.com/culture" class="elementor-item">Culture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58137"><a href="https://theweedblog.com/events" class="elementor-item">Events</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58029"><a href="https://theweedblog.com/growing" class="elementor-item">Growing</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58028"><a href="https://theweedblog.com/industry" class="elementor-item">Industry</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-58135"><a href="https://theweedblog.com/medical" class="elementor-item">Medical</a><ul class="sub-menu elementor-nav-menu--dropdown"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59697"><a href="/tag/missouri-medical-marijuana-program" class="elementor-sub-item">Missouri Medical Marijuana Program</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58034"><a href="https://theweedblog.com/policies" class="elementor-item">Policy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58026"><a href="https://theweedblog.com/science" class="elementor-item">Science</a></li></ul></nav><div class="elementor-menu-toggle" role="button" tabindex="0" aria-label="Menu Toggle" aria-expanded="false"> <i class="eicon-menu-bar" aria-hidden="true"></i> <span class="elementor-screen-only">Menu</span></div><nav class="elementor-nav-menu--dropdown elementor-nav-menu__container" role="navigation" aria-hidden="true"><ul id="menu-2-9481b8d" class="elementor-nav-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-58369"><a href="https://theweedblog.com/" class="elementor-item"><i class="fas fa-home"></i></a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58031"><a href="https://theweedblog.com/advocacy" class="elementor-item">Advocacy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58025"><a href="https://theweedblog.com/cooking" class="elementor-item">Cooking</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-58136"><a href="https://theweedblog.com/culture" class="elementor-item">Culture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58137"><a href="https://theweedblog.com/events" class="elementor-item">Events</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58029"><a href="https://theweedblog.com/growing" class="elementor-item">Growing</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58028"><a href="https://theweedblog.com/industry" class="elementor-item">Industry</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-58135"><a href="https://theweedblog.com/medical" class="elementor-item">Medical</a><ul class="sub-menu elementor-nav-menu--dropdown"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59697"><a href="/tag/missouri-medical-marijuana-program" class="elementor-sub-item">Missouri Medical Marijuana Program</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58034"><a href="https://theweedblog.com/policies" class="elementor-item">Policy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58026"><a href="https://theweedblog.com/science" class="elementor-item">Science</a></li></ul></nav></div></div></div></div></div></div></div></section><section class="elementor-element elementor-element-25adef76 ignore-toc elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="25adef76" data-element_type="section" data-settings="{&quot;background_background&quot;:&quot;classic&quot;}"><div class="elementor-background-overlay"></div><div class="elementor-container elementor-column-gap-no"><div class="elementor-row"><div class="elementor-element elementor-element-5e34d6e elementor-column elementor-col-100 elementor-top-column" data-id="5e34d6e" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-2a32700 elementor-widget elementor-widget-heading" data-id="2a32700" data-element_type="widget" data-widget_type="heading.default"><div class="elementor-widget-container"><h2 class="elementor-heading-title elementor-size-default">Popular Articles</h2></div></div><div class="elementor-element elementor-element-9d8603a elementor-posts--thumbnail-left elementor-grid-3 elementor-grid-tablet-2 elementor-grid-mobile-1 elementor-widget elementor-widget-posts" data-id="9d8603a" data-element_type="widget" data-settings="{&quot;classic_row_gap&quot;:{&quot;unit&quot;:&quot;px&quot;,&quot;size&quot;:10,&quot;sizes&quot;:[]},&quot;classic_columns&quot;:&quot;3&quot;,&quot;classic_columns_tablet&quot;:&quot;2&quot;,&quot;classic_columns_mobile&quot;:&quot;1&quot;}" data-widget_type="posts.classic"><div class="elementor-widget-container"><div class="elementor-posts-container elementor-posts elementor-posts--skin-classic elementor-grid"><article class="elementor-post elementor-grid-item post-58935 post type-post status-publish format-standard has-post-thumbnail hentry category-culture tag-1960s tag-fashion tag-hippies tag-history"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/culture/60s-flower-power" ><div class="elementor-post__thumbnail"><img width="300" height="200" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-300x200.png" class="attachment-medium size-medium lazyload" alt=""   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;fit=300%2C200&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;ssl=1 2560w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-1024x683.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-768x512.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-1536x1024.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-2048x1365.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-2000x1333.jpg?strip=all&amp;lossy=1&amp;ssl=1 2000w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" data-sizes="auto" /><noscript><img width="300" height="200" src="https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;fit=300%2C200&amp;ssl=1" class="attachment-medium size-medium" alt="" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;ssl=1 2560w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-1024x683.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-768x512.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-1536x1024.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-2048x1365.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-2000x1333.jpg?strip=all&amp;lossy=1&amp;ssl=1 2000w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/vasilios-muselimis-S7avQRg8ZLI-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/culture/60s-flower-power" > Flower Power: Cannabis and the Culture of the &#8217;60s </a></h3></div></article><article class="elementor-post elementor-grid-item post-11555 post type-post status-publish format-standard has-post-thumbnail hentry category-culture tag-grinder tag-kief tag-what-is-kief"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/culture/what-is-marijuana-kief" ><div class="elementor-post__thumbnail"><img width="300" height="259" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-300x259.png" class="attachment-medium size-medium lazyload" alt=""   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/KIEF-1.jpg?strip=all&amp;lossy=1&amp;fit=300%2C259&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/KIEF-1.jpg?strip=all&amp;lossy=1&amp;ssl=1 510w, https://theweedblog-com.exactdn.com/wp-content/uploads/KIEF-1-300x259.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/KIEF-1.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w" data-sizes="auto" /><noscript><img width="300" height="259" src="https://theweedblog-com.exactdn.com/wp-content/uploads/KIEF-1.jpg?strip=all&amp;lossy=1&amp;fit=300%2C259&amp;ssl=1" class="attachment-medium size-medium" alt="" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/KIEF-1.jpg?strip=all&amp;lossy=1&amp;ssl=1 510w, https://theweedblog-com.exactdn.com/wp-content/uploads/KIEF-1-300x259.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/KIEF-1.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/culture/what-is-marijuana-kief" > What is Marijuana Kief? </a></h3></div></article><article class="elementor-post elementor-grid-item post-52728 post type-post status-publish format-standard has-post-thumbnail hentry category-growing tag-growing tag-marijuana tag-marijuana-leaf tag-overwatering tag-ph-problems tag-underwatering"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/growing/identify-marijuana-leaf-issues" ><div class="elementor-post__thumbnail"><img width="300" height="284" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-300x284.png" class="attachment-medium size-medium lazyload" alt="marijuana leaf issues"   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/FullSizeRender-18.jpg?strip=all&amp;lossy=1&amp;fit=300%2C284&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/FullSizeRender-18.jpg?strip=all&amp;lossy=1&amp;ssl=1 746w, https://theweedblog-com.exactdn.com/wp-content/uploads/FullSizeRender-18-300x284.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/FullSizeRender-18.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/FullSizeRender-18.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/FullSizeRender-18.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w" data-sizes="auto" /><noscript><img width="300" height="284" src="https://theweedblog-com.exactdn.com/wp-content/uploads/FullSizeRender-18.jpg?strip=all&amp;lossy=1&amp;fit=300%2C284&amp;ssl=1" class="attachment-medium size-medium" alt="marijuana leaf issues" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/FullSizeRender-18.jpg?strip=all&amp;lossy=1&amp;ssl=1 746w, https://theweedblog-com.exactdn.com/wp-content/uploads/FullSizeRender-18-300x284.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/FullSizeRender-18.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/FullSizeRender-18.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/FullSizeRender-18.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/growing/identify-marijuana-leaf-issues" > How to Identify Marijuana Leaf Issues and Their Common Causes </a></h3></div></article><article class="elementor-post elementor-grid-item post-30338 post type-post status-publish format-standard has-post-thumbnail hentry category-marijuana-recipes tag-hot-chocolate tag-recipe"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-marijuana-hot-chocolate" ><div class="elementor-post__thumbnail"><img width="300" height="300" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-300x300.png" class="attachment-medium size-medium lazyload" alt="marijuana hot chocolate"   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-hot-chocolate.jpg?strip=all&amp;lossy=1&amp;fit=300%2C300&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-hot-chocolate.jpg?strip=all&amp;lossy=1&amp;ssl=1 350w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-hot-chocolate-150x150.jpg?strip=all&amp;lossy=1&amp;ssl=1 150w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-hot-chocolate-300x300.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-hot-chocolate-250x250.jpg?strip=all&amp;lossy=1&amp;ssl=1 250w" data-sizes="auto" /><noscript><img width="300" height="300" src="https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-hot-chocolate.jpg?strip=all&amp;lossy=1&amp;fit=300%2C300&amp;ssl=1" class="attachment-medium size-medium" alt="marijuana hot chocolate" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-hot-chocolate.jpg?strip=all&amp;lossy=1&amp;ssl=1 350w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-hot-chocolate-150x150.jpg?strip=all&amp;lossy=1&amp;ssl=1 150w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-hot-chocolate-300x300.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-hot-chocolate-250x250.jpg?strip=all&amp;lossy=1&amp;ssl=1 250w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-marijuana-hot-chocolate" > How To Make Marijuana Hot Chocolate </a></h3></div></article><article class="elementor-post elementor-grid-item post-58842 post type-post status-publish format-standard has-post-thumbnail hentry category-culture tag-beauty-products tag-cbd tag-cbd-skin-products tag-skincare"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/culture/everything-about-cbd-skincare" ><div class="elementor-post__thumbnail"><img width="300" height="200" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-300x200.png" class="attachment-medium size-medium lazyload" alt=""   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;fit=300%2C200&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;ssl=1 2560w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-1024x684.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-768x513.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-1536x1026.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-2048x1367.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-2000x1335.jpg?strip=all&amp;lossy=1&amp;ssl=1 2000w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" data-sizes="auto" /><noscript><img width="300" height="200" src="https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;fit=300%2C200&amp;ssl=1" class="attachment-medium size-medium" alt="" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;ssl=1 2560w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-1024x684.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-768x513.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-1536x1026.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-2048x1367.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-2000x1335.jpg?strip=all&amp;lossy=1&amp;ssl=1 2000w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/sohini-ngl44pFCz-g-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/culture/everything-about-cbd-skincare" > Everything There is To Know About CBD Skincare </a></h3></div></article><article class="elementor-post elementor-grid-item post-58093 post type-post status-publish format-standard has-post-thumbnail hentry category-industry tag-cannabis-events tag-cannabis-industry"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/industry/is-cannabis-industry-affected-by-coronavirus" ><div class="elementor-post__thumbnail"><img width="300" height="200" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-300x200.png" class="attachment-medium size-medium lazyload" alt="coronavirus"   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280.jpg?strip=all&amp;lossy=1&amp;fit=300%2C200&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280.jpg?strip=all&amp;lossy=1&amp;ssl=1 1280w, https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280-1024x682.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280-768x512.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w" data-sizes="auto" /><noscript><img width="300" height="200" src="https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280.jpg?strip=all&amp;lossy=1&amp;fit=300%2C200&amp;ssl=1" class="attachment-medium size-medium" alt="coronavirus" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280.jpg?strip=all&amp;lossy=1&amp;ssl=1 1280w, https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280-1024x682.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280-768x512.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/corona-5174671_1280.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/industry/is-cannabis-industry-affected-by-coronavirus" > Is the Cannabis Industry Being Affected by the Coronavirus? </a></h3></div></article><article class="elementor-post elementor-grid-item post-3036 post type-post status-publish format-standard has-post-thumbnail hentry category-ending-marijuana-prohibition category-cannabis-tips-and-tricks category-opinion tag-dealer tag-seller"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/ending-marijuana-prohibition/how-to-be-a-marijuana-dealer-starting-up" ><div class="elementor-post__thumbnail"><img width="300" height="200" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-300x200.png" class="attachment-medium size-medium lazyload" alt="Selling weed can be easier if you follow these tips and tricks on how to be a legal marijuana dealer"   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;fit=300%2C200&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;ssl=1 2560w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-1024x683.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-768x512.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-1536x1024.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-2048x1366.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" data-sizes="auto" /><noscript><img width="300" height="200" src="https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;fit=300%2C200&amp;ssl=1" class="attachment-medium size-medium" alt="Selling weed can be easier if you follow these tips and tricks on how to be a legal marijuana dealer" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;ssl=1 2560w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-1024x683.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-768x512.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-1536x1024.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-2048x1366.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/add-weed-Bu6BSErSL_M-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/ending-marijuana-prohibition/how-to-be-a-marijuana-dealer-starting-up" > How to Be a Marijuana Dealer Starting Up </a></h3></div></article><article class="elementor-post elementor-grid-item post-8921 post type-post status-publish format-standard has-post-thumbnail hentry category-growing category-marijuana-science tag-pollen tag-subcool"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/growing/how-to-collect-marijuana-pollen-and-use-it" ><div class="elementor-post__thumbnail"><img width="295" height="295" src="https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen.png?strip=all&amp;lossy=1&amp;ssl=1&lazy=2" class="attachment-medium size-medium lazyload" alt=""   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen.png?strip=all&amp;lossy=1&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen-150x150.png?strip=all&amp;lossy=1&amp;ssl=1 150w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen-200x200.png?strip=all&amp;lossy=1&amp;ssl=1 200w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen-96x96.png?strip=all&amp;lossy=1&amp;ssl=1 96w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen-24x24.png?strip=all&amp;lossy=1&amp;ssl=1 24w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen-36x36.png?strip=all&amp;lossy=1&amp;ssl=1 36w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen-48x48.png?strip=all&amp;lossy=1&amp;ssl=1 48w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen-64x64.png?strip=all&amp;lossy=1&amp;ssl=1 64w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen.png?strip=all&amp;lossy=1&amp;ssl=1 295w" data-sizes="auto" /><noscript><img width="295" height="295" src="https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen.png?strip=all&amp;lossy=1&amp;ssl=1" class="attachment-medium size-medium" alt="" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen-150x150.png?strip=all&amp;lossy=1&amp;ssl=1 150w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen-200x200.png?strip=all&amp;lossy=1&amp;ssl=1 200w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen-96x96.png?strip=all&amp;lossy=1&amp;ssl=1 96w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen-24x24.png?strip=all&amp;lossy=1&amp;ssl=1 24w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen-36x36.png?strip=all&amp;lossy=1&amp;ssl=1 36w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen-48x48.png?strip=all&amp;lossy=1&amp;ssl=1 48w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen-64x64.png?strip=all&amp;lossy=1&amp;ssl=1 64w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuana-pollen.png?strip=all&amp;lossy=1&amp;ssl=1 295w" sizes="(max-width: 295px) 100vw, 295px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/growing/how-to-collect-marijuana-pollen-and-use-it" > How To Collect Marijuana Pollen And Use It </a></h3></div></article><article class="elementor-post elementor-grid-item post-6471 post type-post status-publish format-standard has-post-thumbnail hentry category-ending-marijuana-prohibition category-cannabis-tips-and-tricks category-opinion tag-cannabis-dealer tag-dealer tag-hustler tag-marijuana-dealer tag-pot-dealer tag-seller tag-slanger tag-the-game tag-weed-dealer"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/ending-marijuana-prohibition/how-to-be-a-marijuana-dealer-becoming-a-veteran" ><div class="elementor-post__thumbnail"><img width="300" height="300" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-300x300.png" class="attachment-medium size-medium lazyload" alt="marijuana bag"   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/marijuanabag.jpg?strip=all&amp;lossy=1&amp;fit=300%2C300&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/marijuanabag.jpg?strip=all&amp;lossy=1&amp;ssl=1 389w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuanabag-150x150.jpg?strip=all&amp;lossy=1&amp;ssl=1 150w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuanabag-300x300.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuanabag-200x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 200w" data-sizes="auto" /><noscript><img width="300" height="300" src="https://theweedblog-com.exactdn.com/wp-content/uploads/marijuanabag.jpg?strip=all&amp;lossy=1&amp;fit=300%2C300&amp;ssl=1" class="attachment-medium size-medium" alt="marijuana bag" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/marijuanabag.jpg?strip=all&amp;lossy=1&amp;ssl=1 389w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuanabag-150x150.jpg?strip=all&amp;lossy=1&amp;ssl=1 150w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuanabag-300x300.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/marijuanabag-200x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 200w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/ending-marijuana-prohibition/how-to-be-a-marijuana-dealer-becoming-a-veteran" > How To Be A Marijuana Dealer — Becoming A Veteran </a></h3></div></article><article class="elementor-post elementor-grid-item post-58984 post type-post status-publish format-standard has-post-thumbnail hentry category-culture category-medical tag-covid-19 tag-evali tag-vaping"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/medical/uncovering-the-uncommon-commonalities-between-covid-19-and-evali" ><div class="elementor-post__thumbnail"><img width="300" height="200" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-300x200.png" class="attachment-medium size-medium lazyload" alt=""   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280.jpg?strip=all&amp;lossy=1&amp;fit=300%2C200&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280.jpg?strip=all&amp;lossy=1&amp;ssl=1 1280w, https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280-1024x682.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280-768x511.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w" data-sizes="auto" /><noscript><img width="300" height="200" src="https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280.jpg?strip=all&amp;lossy=1&amp;fit=300%2C200&amp;ssl=1" class="attachment-medium size-medium" alt="" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280.jpg?strip=all&amp;lossy=1&amp;ssl=1 1280w, https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280-1024x682.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280-768x511.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/upper-body-944557_1280.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/medical/uncovering-the-uncommon-commonalities-between-covid-19-and-evali" > Uncovering the Uncommon: Commonalities Between COVID-19 and EVALI </a></h3></div></article><article class="elementor-post elementor-grid-item post-39881 post type-post status-publish format-standard has-post-thumbnail hentry category-culture tag-bad-dabs tag-concentrates tag-dab tag-dabs tag-dabs-good-or-bad tag-good-dabs tag-udoxi-scientific"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/culture/how-to-tell-if-marijuana-dabs-are-good-or-bad" ><div class="elementor-post__thumbnail"><img width="240" height="300" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-240x300.png" class="attachment-medium size-medium lazyload" alt="How to tell if dabs are good or bad and if you got your money&#039;s worth for your weed concentrates"   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1.jpg?strip=all&amp;lossy=1&amp;fit=240%2C300&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1-240x300.jpg?strip=all&amp;lossy=1&amp;ssl=1 240w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1-819x1024.jpg?strip=all&amp;lossy=1&amp;ssl=1 819w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1-768x960.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1-1229x1536.jpg?strip=all&amp;lossy=1&amp;ssl=1 1229w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1-1638x2048.jpg?strip=all&amp;lossy=1&amp;ssl=1 1638w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1.jpg?strip=all&amp;lossy=1&amp;w=320&amp;ssl=1 320w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" data-sizes="auto" /><noscript><img width="240" height="300" src="https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1.jpg?strip=all&amp;lossy=1&amp;fit=240%2C300&amp;ssl=1" class="attachment-medium size-medium" alt="How to tell if dabs are good or bad and if you got your money&#039;s worth for your weed concentrates" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1-240x300.jpg?strip=all&amp;lossy=1&amp;ssl=1 240w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1-819x1024.jpg?strip=all&amp;lossy=1&amp;ssl=1 819w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1-768x960.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1-1229x1536.jpg?strip=all&amp;lossy=1&amp;ssl=1 1229w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1-1638x2048.jpg?strip=all&amp;lossy=1&amp;ssl=1 1638w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1.jpg?strip=all&amp;lossy=1&amp;w=320&amp;ssl=1 320w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/grav-32ZZe52ehkY-unsplash-1.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" sizes="(max-width: 240px) 100vw, 240px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/culture/how-to-tell-if-marijuana-dabs-are-good-or-bad" > How To Tell If Marijuana Dabs Are Good Or Bad </a></h3></div></article><article class="elementor-post elementor-grid-item post-35362 post type-post status-publish format-standard has-post-thumbnail hentry category-growing tag-fertilizer tag-fertilizers"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/growing/the-best-most-popular-marijuana-fertilizers" ><div class="elementor-post__thumbnail"><img width="300" height="169" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-300x169.png" class="attachment-medium size-medium lazyload" alt=""   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;fit=300%2C169&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;ssl=1 2560w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-300x169.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-1024x576.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-768x432.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-1536x864.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-2048x1152.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" data-sizes="auto" /><noscript><img width="300" height="169" src="https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;fit=300%2C169&amp;ssl=1" class="attachment-medium size-medium" alt="" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;ssl=1 2560w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-300x169.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-1024x576.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-768x432.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-1536x864.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-2048x1152.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/popular-marijuana-fertilizers-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/growing/the-best-most-popular-marijuana-fertilizers" > What are the Best and Most Popular Marijuana Fertilizers and Nutrients? </a></h3></div></article><article class="elementor-post elementor-grid-item post-1617 post type-post status-publish format-standard has-post-thumbnail hentry category-growing category-cannabis-tips-and-tricks tag-dried-pot tag-dried-weed tag-dry-marijuana tag-dry-pot tag-dry-weed tag-moisture tag-orange-peels tag-over-dried-marijuana tag-overdried-marijuana tag-overdry-marijuana"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/growing/the-best-way-to-add-moisture-to-over-dry-marijuana" ><div class="elementor-post__thumbnail"><img width="300" height="300" src="https://theweedblog-com.exactdn.com/wp-content/uploads/over-dry-marijuana.jpg?strip=all&amp;lossy=1&amp;ssl=1&lazy=2" class="attachment-medium size-medium lazyload" alt="over dry cannabis"   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/over-dry-marijuana.jpg?strip=all&amp;lossy=1&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/over-dry-marijuana.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/over-dry-marijuana-150x150.jpg?strip=all&amp;lossy=1&amp;ssl=1 150w, https://theweedblog-com.exactdn.com/wp-content/uploads/over-dry-marijuana-100x100.jpg?strip=all&amp;lossy=1&amp;ssl=1 100w, https://theweedblog-com.exactdn.com/wp-content/uploads/over-dry-marijuana-280x280.jpg?strip=all&amp;lossy=1&amp;ssl=1 280w" data-sizes="auto" /><noscript><img width="300" height="300" src="https://theweedblog-com.exactdn.com/wp-content/uploads/over-dry-marijuana.jpg?strip=all&amp;lossy=1&amp;ssl=1" class="attachment-medium size-medium" alt="over dry cannabis" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/over-dry-marijuana.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/over-dry-marijuana-150x150.jpg?strip=all&amp;lossy=1&amp;ssl=1 150w, https://theweedblog-com.exactdn.com/wp-content/uploads/over-dry-marijuana-100x100.jpg?strip=all&amp;lossy=1&amp;ssl=1 100w, https://theweedblog-com.exactdn.com/wp-content/uploads/over-dry-marijuana-280x280.jpg?strip=all&amp;lossy=1&amp;ssl=1 280w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/growing/the-best-way-to-add-moisture-to-over-dry-marijuana" > The Best Way to Add Moisture to Over-Dry Marijuana </a></h3></div></article><article class="elementor-post elementor-grid-item post-40369 post type-post status-publish format-standard has-post-thumbnail hentry category-growing tag-bushy-dense-marijuana-plants"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/growing/how-to-grow-dense-and-bushy-marijuana-plants" ><div class="elementor-post__thumbnail"><img width="300" height="219" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-300x219.png" class="attachment-medium size-medium lazyload" alt=""   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants.jpg?strip=all&amp;lossy=1&amp;fit=300%2C219&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants.jpg?strip=all&amp;lossy=1&amp;ssl=1 2000w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants-300x219.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants-1024x748.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants-768x561.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants-1536x1122.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" data-sizes="auto" /><noscript><img width="300" height="219" src="https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants.jpg?strip=all&amp;lossy=1&amp;fit=300%2C219&amp;ssl=1" class="attachment-medium size-medium" alt="" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants.jpg?strip=all&amp;lossy=1&amp;ssl=1 2000w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants-300x219.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants-1024x748.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants-768x561.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants-1536x1122.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/grow-dense-bushy-marijuana-plants.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/growing/how-to-grow-dense-and-bushy-marijuana-plants" > How To Grow Dense And Bushy Marijuana Plants </a></h3></div></article><article class="elementor-post elementor-grid-item post-1340 post type-post status-publish format-standard has-post-thumbnail hentry category-growing tag-cannabis-and-health tag-health tag-medical-cannabis"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/growing/the-healthiest-ways-to-get-high" ><div class="elementor-post__thumbnail"><img width="300" height="184" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-300x184.png" class="attachment-medium size-medium lazyload" alt=""   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920.jpg?strip=all&amp;lossy=1&amp;fit=300%2C184&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920.jpg?strip=all&amp;lossy=1&amp;ssl=1 1920w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920-300x184.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920-1024x627.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920-768x470.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920-1536x941.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w" data-sizes="auto" /><noscript><img width="300" height="184" src="https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920.jpg?strip=all&amp;lossy=1&amp;fit=300%2C184&amp;ssl=1" class="attachment-medium size-medium" alt="" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920.jpg?strip=all&amp;lossy=1&amp;ssl=1 1920w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920-300x184.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920-1024x627.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920-768x470.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920-1536x941.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/cannabis-2150543_1920.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/growing/the-healthiest-ways-to-get-high" > The Healthiest Ways to Get High </a></h3></div></article><article class="elementor-post elementor-grid-item post-7224 post type-post status-publish format-standard has-post-thumbnail hentry category-marijuana-strain-reviews tag-white-diamonds"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/marijuana-strain-reviews/white-diamonds-marijuana-strain-review" ><div class="elementor-post__thumbnail"><img width="150" height="150" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-150x150.png" class="attachment-medium size-medium lazyload" alt="White Diamonds Cannabis" data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/White-Diamonds-Thumbnail.jpg?strip=all&amp;lossy=1&amp;fit=150%2C150&amp;ssl=1" loading="lazy" /><noscript><img width="150" height="150" src="https://theweedblog-com.exactdn.com/wp-content/uploads/White-Diamonds-Thumbnail.jpg?strip=all&amp;lossy=1&amp;fit=150%2C150&amp;ssl=1" class="attachment-medium size-medium" alt="White Diamonds Cannabis" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/marijuana-strain-reviews/white-diamonds-marijuana-strain-review" > White Diamonds Marijuana Strain Review </a></h3></div></article><article class="elementor-post elementor-grid-item post-869 post type-post status-publish format-standard has-post-thumbnail hentry category-culture"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/culture/15-ultimate-munchie-foods-for-stoners" ><div class="elementor-post__thumbnail"><img width="209" height="300" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-209x300.png" class="attachment-medium size-medium lazyload" alt=""   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-scaled.jpg?strip=all&amp;lossy=1&amp;fit=209%2C300&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-scaled.jpg?strip=all&amp;lossy=1&amp;ssl=1 1781w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-209x300.jpg?strip=all&amp;lossy=1&amp;ssl=1 209w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-712x1024.jpg?strip=all&amp;lossy=1&amp;ssl=1 712w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-768x1104.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-1069x1536.jpg?strip=all&amp;lossy=1&amp;ssl=1 1069w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-1425x2048.jpg?strip=all&amp;lossy=1&amp;ssl=1 1425w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-scaled.jpg?strip=all&amp;lossy=1&amp;w=320&amp;ssl=1 320w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w" data-sizes="auto" /><noscript><img width="209" height="300" src="https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-scaled.jpg?strip=all&amp;lossy=1&amp;fit=209%2C300&amp;ssl=1" class="attachment-medium size-medium" alt="" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-scaled.jpg?strip=all&amp;lossy=1&amp;ssl=1 1781w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-209x300.jpg?strip=all&amp;lossy=1&amp;ssl=1 209w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-712x1024.jpg?strip=all&amp;lossy=1&amp;ssl=1 712w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-768x1104.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-1069x1536.jpg?strip=all&amp;lossy=1&amp;ssl=1 1069w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-1425x2048.jpg?strip=all&amp;lossy=1&amp;ssl=1 1425w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-scaled.jpg?strip=all&amp;lossy=1&amp;w=320&amp;ssl=1 320w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/best-stoner-foods-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w" sizes="(max-width: 209px) 100vw, 209px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/culture/15-ultimate-munchie-foods-for-stoners" > 15 Ultimate Munchie Foods for Stoners </a></h3></div></article><article class="elementor-post elementor-grid-item post-11557 post type-post status-publish format-standard has-post-thumbnail hentry category-growing category-cannabis-tips-and-tricks tag-cannabis-plant tag-indica tag-indica-vs-sativa tag-ruderalis tag-sativa"> <a class="elementor-post__thumbnail__link" href="https://theweedblog.com/growing/the-difference-between-indica-and-sativa-marijuana-plants" ><div class="elementor-post__thumbnail"><img width="300" height="200" src="https://theweedblog-com.exactdn.com/wp-content/ewww/lazy/placeholder-300x200.png" class="attachment-medium size-medium lazyload" alt="Indica and sativa are two types of cannabis that have different effects on the body and mind"   data-src="https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;fit=300%2C200&amp;ssl=1" loading="lazy" data-srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;ssl=1 2560w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-1024x684.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-768x513.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-1536x1026.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-2048x1368.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" data-sizes="auto" /><noscript><img width="300" height="200" src="https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;fit=300%2C200&amp;ssl=1" class="attachment-medium size-medium" alt="Indica and sativa are two types of cannabis that have different effects on the body and mind" srcset="https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;ssl=1 2560w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-300x200.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-1024x684.jpg?strip=all&amp;lossy=1&amp;ssl=1 1024w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-768x513.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-1536x1026.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-2048x1368.jpg?strip=all&amp;lossy=1&amp;ssl=1 2048w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=160&amp;ssl=1 160w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=480&amp;ssl=1 480w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=640&amp;ssl=1 640w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1600&amp;ssl=1 1600w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=2400&amp;ssl=1 2400w, https://theweedblog-com.exactdn.com/wp-content/uploads/gras-grun-a1uuc_67now-unsplash-scaled.jpg?strip=all&amp;lossy=1&amp;w=1920&amp;ssl=1 1920w" sizes="(max-width: 300px) 100vw, 300px" data-eio="l" /></noscript></div> </a><div class="elementor-post__text"><h3 class="elementor-post__title"> <a href="https://theweedblog.com/growing/the-difference-between-indica-and-sativa-marijuana-plants" > What Is The Difference Between Indica and Sativa? </a></h3></div></article></div></div></div></div></div></div></div></div></section><section class="elementor-element elementor-element-324bb73 ignore-toc elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="324bb73" data-element_type="section" data-settings="{&quot;background_background&quot;:&quot;classic&quot;}"><div class="elementor-container elementor-column-gap-default"><div class="elementor-row"><div class="elementor-element elementor-element-4e432b3 elementor-column elementor-col-100 elementor-top-column" data-id="4e432b3" data-element_type="column"><div class="elementor-column-wrap  elementor-element-populated"><div class="elementor-widget-wrap"><div class="elementor-element elementor-element-7e4ac21 elementor-widget__width-auto elementor-widget-mobile__width-inherit elementor-widget elementor-widget-heading" data-id="7e4ac21" data-element_type="widget" data-widget_type="heading.default"><div class="elementor-widget-container"><h2 class="elementor-heading-title elementor-size-default"><span style="color: #79ab87;">The Weed Blog</span> <span style="color: #444;">•</span> All Rights Reserved © 2020​</h2></div></div><div class="elementor-element elementor-element-151cfaf elementor-widget elementor-widget-html" data-id="151cfaf" data-element_type="widget" data-widget_type="html.default"><div class="elementor-widget-container"><div class="nav-category inline"> <input type="checkbox" class="read-more-state" id="collapse-cat-0"> <label for="collapse-cat-0" class="read-more-trigger">Marijuana News</label><p class="read-more-wrap"> <span class="read-more-target"> <a href="https://theweedblog.com/marijuana-strain-reviews/ace-of-spades-marijuana-strain-review-and-pictures" title="Ace Of Spades Marijuana Strain Review And Pictures">Ace Of Spades Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-marijuana-taffy" title="How To Make Marijuana Taffy">How To Make Marijuana Taffy</a> <br> <a href="https://theweedblog.com/medical-marijuana-policy/beware-consumption-of-low-quality-poorly-purged-butane-hash-oil" title="Beware Consumption Of Low-Quality">Beware Consumption Of Low-Quality</a> <br> <a href="https://theweedblog.com/growing/how-to-get-rid-of-thrips-on-your-marijuana-plants" title="How To Get Rid Of Thrips On Your Marijuana Plants">How To Get Rid Of Thrips On Your Marijuana Plants</a> <br> <a href="https://theweedblog.com/stoner-pics/mike-tyson-marijuana-strain-pictures" title="Mike Tyson Marijuana Strain Pictures">Mike Tyson Marijuana Strain Pictures</a> <br> <a href="https://theweedblog.com/growing/how-to-get-rid-of-all-pests-and-diseases-on-marijuana-plants" title="How To Get Rid Of All Pests And Diseases On Marijuana Plants">How To Get Rid Of All Pests And Diseases On Marijuana Plants</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/vanilla-kush-marijuana-strain-review-and-pictures" title="Vanilla Kush Marijuana Strain Review And Pictures">Vanilla Kush Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/medical/can-you-get-discounts-on-medical-marijuana-in-canada" title="Can you Get Discounts on Medical Marijuana in Canada?">Can you Get Discounts on Medical Marijuana in Canada?</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-choose-the-right-bong-for-you" title="How To Choose The Right Bong For You">How To Choose The Right Bong For You</a> <br> <a href="https://theweedblog.com/marijuana-entertainment/does-snoop-really-smoke-81-blunts-a-day" title="Does Snoop Really Smoke 81 Blunts A Day?">Does Snoop Really Smoke 81 Blunts A Day?</a> <br> <a href="https://theweedblog.com/culture/best-way-to-do-dabs" title="What is the Best Way to Do Dabs? A Little Dab Will Do!">What is the Best Way to Do Dabs? A Little Dab Will Do!</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/chocolate-banana-kush-marijuana-strain-review-and-pictures" title="Chocolate Banana Kush Marijuana Strain Review And Pictures">Chocolate Banana Kush Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/cin-x-true-north-extracts-co2-vape-pen-cartridge-review" title="Cin X True North Extracts CO2 Vape Pen Cartridge Review">Cin X True North Extracts CO2 Vape Pen Cartridge Review</a> <br> <a href="https://theweedblog.com/growing/how-to-recognize-quality-marijuana-seeds" title="How To Recognize Quality Marijuana Seeds">How To Recognize Quality Marijuana Seeds</a> <br> <a href="https://theweedblog.com/science/god-cannabis-and-lots-of-conflicting-information" title="God">God</a> <br> <a href="https://theweedblog.com/culture/new-study-says-mary-jane-makes-you-horny-er" title="New Study Says Mary Jane Makes You Horny (er)">New Study Says Mary Jane Makes You Horny (er)</a> <br> <a href="https://theweedblog.com/growing/marijuana-container-planting-a-primer" title="Marijuana Container Planting: A Primer">Marijuana Container Planting: A Primer</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/platinum-bubba-marijuana-strain-review-and-pictures" title="Platinum Bubba Marijuana Strain Review And Pictures">Platinum Bubba Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/culture/everything-about-cbd-skincare" title="Everything There is To Know About CBD Skincare">Everything There is To Know About CBD Skincare</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks" title="Marijuana Tips and Tricks Archives">Marijuana Tips and Tricks Archives</a> <br> <a href="https://theweedblog.com/growing/how-to-dry-marijuana-by-jorge-cervantes" title="How To Dry Marijuana By Jorge Cervantes">How To Dry Marijuana By Jorge Cervantes</a> <br> <a href="https://theweedblog.com/medical-marijuana-policy/how-much-does-medical-marijuana-cost-in-illinois" title="How Much Does Medical Marijuana Cost In Illinois?">How Much Does Medical Marijuana Cost In Illinois?</a> <br> <a href="https://theweedblog.com/culture/420-coronavirus-2020-virtual-lineup" title="4/20 in the Time of Coronavirus: 2020â€™s Virtual Lineup">4/20 in the Time of Coronavirus: 2020â€™s Virtual Lineup</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/mango-marijuana-strain-review-and-pictures" title="Mango Marijuana Strain Review And Pictures">Mango Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/culture/5-marijuana-strains-for-anxiety" title="5 Marijuana Strains for Anxiety - The Weed Blog">5 Marijuana Strains for Anxiety - The Weed Blog</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/lemon-skunk-marijuana-strain-review" title="Lemon Skunk Marijuana Strain Review">Lemon Skunk Marijuana Strain Review</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/banana-og-marijuana-strain-review-and-pictures" title="Banana OG Marijuana Strain Review And Pictures">Banana OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/reasons-why-marijuana-dealers-cut-off-customers" title="Reasons Why Marijuana Dealers Cut Off Customers">Reasons Why Marijuana Dealers Cut Off Customers</a> <br> <a href="https://theweedblog.com/growing/how-to-recognize-manganese-deficiencies-on-marijuana-plants" title="How To Recognize Manganese Deficiencies On Marijuana Plants">How To Recognize Manganese Deficiencies On Marijuana Plants</a> <br> <a href="https://theweedblog.com/culture/the-top-7-gifts-for-your-stoner-sweetie-on-valentine-s-day-2019" title="The Top 7 Gifts for your Stoner Sweetie on Valentineâ€™s Day 2019">The Top 7 Gifts for your Stoner Sweetie on Valentineâ€™s Day 2019</a> <br> <a href="https://theweedblog.com/growing/better-growing-cannabis-hydroponics-or-soil" title="Which One is Better For Growing Cannabis Hydroponics or Soil?">Which One is Better For Growing Cannabis Hydroponics or Soil?</a> <br> <a href="https://theweedblog.com/marijuana-pics/el-matadore-marijuana-strain-pictures" title="El Matadore Marijuana Strain Pictures">El Matadore Marijuana Strain Pictures</a> <br> <a href="https://theweedblog.com/growing/how-to-grow-the-jack-herer-marijuana-strain-indoors" title="How To Grow The Jack Herer Marijuana Strain Indoors">How To Grow The Jack Herer Marijuana Strain Indoors</a> <br> <a href="https://theweedblog.com/opinion/what-is-the-best-job-for-a-stoner" title="What Is The Best Job For A Stoner?">What Is The Best Job For A Stoner?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/bubba-kush-marijuana-strain-review-and-pictures" title="Bubba Kush Marijuana Strain Review And Pictures">Bubba Kush Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/lemon-haze-marijuana-strain-review-and-pictures" title="Lemon Haze Marijuana Strain Review And Pictures">Lemon Haze Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/pineapple-express-marijuana-strain-review-and-pictures" title="Pineapple Express Marijuana Strain Review And Pictures">Pineapple Express Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-pics/black-mamba-marijuana-strain-pictures" title="Black Mamba Marijuana Strain Pictures">Black Mamba Marijuana Strain Pictures</a> <br> <a href="https://theweedblog.com/culture/what-is-710-and-how-did-710-become-a-stoner-holiday" title="What Is '710' And How Did 7/10 Become A Stoner Holiday?">What Is '710' And How Did 7/10 Become A Stoner Holiday?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/larry-og-marijuana-strain-review-and-pictures" title="Larry OG Marijuana Strain Review And Pictures">Larry OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/low-temp-dabs-vs-high-temp-dabs" title="Low Temp Dabs Vs. High Temp Dabs">Low Temp Dabs Vs. High Temp Dabs</a> <br> <a href="https://theweedblog.com/culture/where-to-buy-best-dab-rigs" title="Where To Buy The Best Dab Rigs Under $100">Where To Buy The Best Dab Rigs Under $100</a> <br> <a href="https://theweedblog.com/cooking/canada-legalizes-cannabis-but-not-edibles" title="Canada Legalizes Cannabis">Canada Legalizes Cannabis</a> <br> <a href="https://theweedblog.com/culture/csc-cannabis-strains-community" title="CSC: Cannabis Strains Community">CSC: Cannabis Strains Community</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-smoke-a-joint-without-rolling-papers" title="How To Smoke A Joint Without Rolling Papers">How To Smoke A Joint Without Rolling Papers</a> <br> <a href="https://theweedblog.com/growing/how-to-grow-the-cheese-marijuana-strain-indoors" title="How To Grow The Cheese Marijuana Strain Indoors">How To Grow The Cheese Marijuana Strain Indoors</a> <br> <a href="https://theweedblog.com/growing/super-cropping-marijuana-pruning-techniques" title="Super Cropping - Marijuana Pruning Techniques">Super Cropping - Marijuana Pruning Techniques</a> <br> <a href="https://theweedblog.com/industry/coronavirus-pandemic-cannabis-partnerships-missouri" title="Despite Coronavirus">Despite Coronavirus</a> <br> <a href="https://theweedblog.com/marijuana-products/how-to-put-together-the-perfect-bong-for-you" title="How To Put Together The Perfect Bong (For You)">How To Put Together The Perfect Bong (For You)</a> <br> <a href="https://theweedblog.com/science/synthetic-vs-natural-cannabis-what-s-the-difference" title="Synthetic vs. Natural Cannabis: Whatâ€™s the Difference?">Synthetic vs. Natural Cannabis: Whatâ€™s the Difference?</a> <br> <a href="https://theweedblog.com/growing/how-to-grow-northern-lights-marijuana-indoors" title="How To Grow Northern Lights Marijuana Indoors">How To Grow Northern Lights Marijuana Indoors</a> <br> <a href="https://theweedblog.com/growing/watering-tips-and-techniques-for-outdoor-marijuana-growers" title="Watering Tips And Techniques For Outdoor Marijuana Growers">Watering Tips And Techniques For Outdoor Marijuana Growers</a> <br> <a href="https://theweedblog.com/growing/does-playing-music-for-marijuana-plants-help-them-grow" title="Does Playing Music For Marijuana Plants Help Them Grow?">Does Playing Music For Marijuana Plants Help Them Grow?</a> <br> <a href="https://theweedblog.com/medical/can-cbd-help-social-anxiety" title="Can CBD Help Social Anxiety?">Can CBD Help Social Anxiety?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/durban-poison-marijuana-strain-review-and-pictures" title="Durban Poison Marijuana Strain Review And Pictures">Durban Poison Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/cali-mist-marijuana-strain-review-and-pictures" title="Cali Mist Marijuana Strain Review And Pictures">Cali Mist Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/death-star-marijuana-strain-review-and-pictures" title="Death Star Marijuana Strain Review And Pictures">Death Star Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/culture/60s-flower-power" title="Flower Power: Cannabis and the Culture of the '60s">Flower Power: Cannabis and the Culture of the '60s</a> <br> <a href="https://theweedblog.com/ending-marijuana-prohibition/the-two-most-expensive-cannabis-strains" title="The Two Most Expensive Weed Strains In The World">The Two Most Expensive Weed Strains In The World</a> <br> <a href="https://theweedblog.com/marijuana-video/marijuana-strain-review-amf-og" title="Marijuana Strain Review - AMF OG">Marijuana Strain Review - AMF OG</a> <br> <a href="https://theweedblog.com/tag/cream-og" title="cream og Archives">cream og Archives</a> <br> <a href="https://theweedblog.com/growing/five-steps-to-increase-your-marijuana-garden-yields" title="Five Steps To Increase Your Marijuana Garden Yields">Five Steps To Increase Your Marijuana Garden Yields</a> <br> <a href="https://theweedblog.com/growing/how-to-grow-purple-haze-marijuana-indoors" title="How To Grow Purple Haze Marijuana Indoors">How To Grow Purple Haze Marijuana Indoors</a> <br> <a href="https://theweedblog.com/growing/mice-love-to-eat-your-marijuana-plants" title="Mice Love To Eat Your Marijuana Plants">Mice Love To Eat Your Marijuana Plants</a> <br> <a href="https://theweedblog.com/industry/cloverleaf-university-gives-you-resources-for-success-in-the-cannabis-industry" title="Cloverleaf University Gives you Resources for Success in the Cannabis Industry">Cloverleaf University Gives you Resources for Success in the Cannabis Industry</a> <br> <a href="https://theweedblog.com/growing/when-is-the-best-time-to-harvest-outdoor-marijuana-plants" title="Harvest Time for Your Outdoor Marijuana Plants - The Weed Blog">Harvest Time for Your Outdoor Marijuana Plants - The Weed Blog</a> <br> <a href="https://theweedblog.com/opinion/how-do-you-know-if-someone-smokes-marijuana" title="How Do You Know If Someone Smokes Marijuana?">How Do You Know If Someone Smokes Marijuana?</a> <br> <a href="https://theweedblog.com/growing/what-you-need-to-know-autoflowering-cannabis-seeds" title="What You Need to Know About Autoflowering Cannabis Seeds">What You Need to Know About Autoflowering Cannabis Seeds</a> <br> <a href="https://theweedblog.com/growing/figuring-out-the-right-commercial-dehumidifier-for-your-grow-room" title="Figuring Out the Right Commercial Dehumidifier for Your Grow Room">Figuring Out the Right Commercial Dehumidifier for Your Grow Room</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/blue-haze-marijuana-strain-review" title="Blue Haze Marijuana Strain Review">Blue Haze Marijuana Strain Review</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/vader-og-marijuana-strain-review-and-pictures" title="Vader OG Marijuana Strain Review And Pictures">Vader OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/science/the-science-behind-cbd-and-drug-tests-everything-you-need-to-know" title="The Science Behind CBD and Drug Tests: Everything You Need to Know">The Science Behind CBD and Drug Tests: Everything You Need to Know</a> <br> <a href="https://theweedblog.com/medical/cannabis-and-schizophrenia" title="Cannabis and Schizophrenia">Cannabis and Schizophrenia</a> <br> <a href="https://theweedblog.com/marijuana-pics/skittles-marijuana-strain-pictures" title="Skittles Marijuana Strain Pictures">Skittles Marijuana Strain Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/phantom-og-marijuana-strain-review-and-pictures" title="Phantom OG Marijuana Strain Review And Pictures">Phantom OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/how-to-recognize-magnesium-deficiencies-in-marijuana-plants" title="How To Recognize Magnesium Deficiencies In Marijuana Plants">How To Recognize Magnesium Deficiencies In Marijuana Plants</a> <br> <a href="https://theweedblog.com/industry/yocan-vaporizers-for-2019" title="Yocan's Vaporizers for 2019">Yocan's Vaporizers for 2019</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/chuck-norris-marijuana-strain" title="Chuck Norris Marijuana Strain">Chuck Norris Marijuana Strain</a> <br> <a href="https://theweedblog.com/culture/the-top-6-gifts-for-the-canna-dad-on-father-s-day-2018" title="The Top 6 Gifts for the Canna-Dad on Fatherâ€™s Day 2018">The Top 6 Gifts for the Canna-Dad on Fatherâ€™s Day 2018</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/blue-cheese-marijuana-strain-review-and-pictures" title="Blue Cheese Marijuana Strain Review And Pictures">Blue Cheese Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/21-tips-to-solve-nutrients-deficiencies-in-marijuana-plants" title="21 Tips To Solve Nutrients Deficiencies In Marijuana Plants">21 Tips To Solve Nutrients Deficiencies In Marijuana Plants</a> <br> <a href="https://theweedblog.com/industry/high-times-lays-off-staff-and-shutters-acquired-magazines" title="High Times Lays off Staff and Shutters Two of its Acquired Magazines">High Times Lays off Staff and Shutters Two of its Acquired Magazines</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/easy-marijuana-butter-recipe" title="Marijuana Butter: An Easy Recipe for Any Dish - The Weed Blog">Marijuana Butter: An Easy Recipe for Any Dish - The Weed Blog</a> <br> <a href="https://theweedblog.com/policies/descheduling-vs-rescheduling-not-all-paths-to-legalization-are-created-equal" title="Descheduling vs. Rescheduling Marijuana">Descheduling vs. Rescheduling Marijuana</a> <br> <a href="https://theweedblog.com/marijuana-products/get-quality-marijuana-seeds-from-seed-supreme" title="Get Quality Marijuana Seeds From Seed Supreme">Get Quality Marijuana Seeds From Seed Supreme</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/does-baptizing-your-marijuana-joint-make-it-burn-better" title="Does 'Baptizing' Your Marijuana Joint Make It Burn Better?">Does 'Baptizing' Your Marijuana Joint Make It Burn Better?</a> <br> <a href="https://theweedblog.com/growing/how-to-grow-big-bud-marijuana-indoors" title="How To Grow Big Bud Marijuana Indoors">How To Grow Big Bud Marijuana Indoors</a> <br> <a href="https://theweedblog.com/growing/marijuana-plant-nutrient-deficiency-phosphorus" title="Marijuana Plant Nutrient Deficiency - Phosphorus">Marijuana Plant Nutrient Deficiency - Phosphorus</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/green-crack-marijuana-strain-review-and-pictures" title="Green Crack Marijuana Strain Review And Pictures">Green Crack Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/medical/coronavirus-charlotte-figi-charlottes-web-cannabis-strain" title="Coronavirus Claims Charlotte Figi">Coronavirus Claims Charlotte Figi</a> <br> <a href="https://theweedblog.com/growing/nutrient-burn-and-marijuana-plants" title="Nutrient Burn And Marijuana Plants">Nutrient Burn And Marijuana Plants</a> <br> <a href="https://theweedblog.com/growing/what-is-the-best-way-to-grow-marijuana-outdoors" title="What Is The Best Way To Grow Marijuana Outdoors?">What Is The Best Way To Grow Marijuana Outdoors?</a> <br> <a href="https://theweedblog.com/culture/how-to-pick-the-perfect-vaporizer-flowchart" title="How to Pick the Perfect Vaporizer (flowchart)">How to Pick the Perfect Vaporizer (flowchart)</a> <br> <a href="https://theweedblog.com/medical/the-top-5-apps-for-medical-cannabis-users" title="The Top 5 Apps for Medical Cannabis Users">The Top 5 Apps for Medical Cannabis Users</a> <br> <a href="https://theweedblog.com/growing/a-fungus-among-us-how-humidity-control-keeps-bud-rot-at-bay" title="A fungus among us: How humidity control keeps bud rot at bay">A fungus among us: How humidity control keeps bud rot at bay</a> <br> <a href="https://theweedblog.com/growing/the-trim-daddy-2-0-electric-hand-trimmer-review" title="The Trim Daddy 2.0 electric hand trimmer review">The Trim Daddy 2.0 electric hand trimmer review</a> <br> <a href="https://theweedblog.com/growing/troubleshooting-for-your-indoor-marijuana-grow" title="Troubleshooting For Your Indoor Marijuana Grow">Troubleshooting For Your Indoor Marijuana Grow</a> <br> <a href="https://theweedblog.com/culture/5-best-marijuana-strains-for-managing-pain" title="5 Best Marijuana Strains for Managing Pain - The Weed Blog">5 Best Marijuana Strains for Managing Pain - The Weed Blog</a> <br> <a href="https://theweedblog.com/culture/what-are-dabs" title="What are Dabs and The Dab Phenomenon - The Weed Blog">What are Dabs and The Dab Phenomenon - The Weed Blog</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-marijuana-scrambled-eggs" title="How To Make Marijuana Scrambled Eggs">How To Make Marijuana Scrambled Eggs</a> <br> <a href="https://theweedblog.com/growing/what-budget-do-you-need-for-growing-marijuana-at-home" title="What Budget do You Need for Growing Marijuana at Home?">What Budget do You Need for Growing Marijuana at Home?</a> <br> <a href="https://theweedblog.com/growing/what-to-do-when-your-marijuana-grow-room-gets-hot" title="What To Do When Your Marijuana Grow Room Gets Hot">What To Do When Your Marijuana Grow Room Gets Hot</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/frequently-asked-questions-about-purging-bho" title="Frequently Asked Questions About Purging BHO">Frequently Asked Questions About Purging BHO</a> <br> <a href="https://theweedblog.com/growing/grow-lights-led-vs-hid-operating-costs" title="Grow Lights - LED vs. HID Operating Costs">Grow Lights - LED vs. HID Operating Costs</a> <br> <a href="https://theweedblog.com/history/illegal-drugs-timeline" title="A Timeline of the Federal Legality of 12 Drugs in the United States">A Timeline of the Federal Legality of 12 Drugs in the United States</a> <br> <a href="https://theweedblog.com/culture/how-to-use-a-dab-rig-in-less-than-5-minutes" title="How to Use A Dab Rig in Less Than 5 Minutes">How to Use A Dab Rig in Less Than 5 Minutes</a> <br> <a href="https://theweedblog.com/growing/make-thc-active-during-the-marijuana-drying-process" title="Make THC Active During The Marijuana Drying Process">Make THC Active During The Marijuana Drying Process</a> <br> <a href="https://theweedblog.com/growing/sexing-your-outdoor-marijuana-plants" title="Sexing Your Outdoor Marijuana Plants">Sexing Your Outdoor Marijuana Plants</a> <br> <a href="https://theweedblog.com/marijuana-business-news/how-much-does-a-marijuana-blunt-roller-job-pay-in-the-music-industry" title="How Much Does A Marijuana Blunt Roller Job Pay In The Music Industry?">How Much Does A Marijuana Blunt Roller Job Pay In The Music Industry?</a> <br> <a href="https://theweedblog.com/marijuana-products/concentrate-review-marley-natural" title="Concentrate Review: Marley Natural - The Weed Blog">Concentrate Review: Marley Natural - The Weed Blog</a> <br> <a href="https://theweedblog.com/growing/how-to-hide-your-outdoor-marijuana-plants" title="How To Hide Your Outdoor Marijuana Plants">How To Hide Your Outdoor Marijuana Plants</a> <br> <a href="https://theweedblog.com/marijuana-science/cats-and-dogs-like-marijuana-too" title="Cats And Dogs Like Marijuana Too">Cats And Dogs Like Marijuana Too</a> <br> <a href="https://theweedblog.com/science/does-cannabis-make-you-lonely-or-happy-when-by-yourself" title="Does Cannabis Make You Lonely or Happy When by Yourself?">Does Cannabis Make You Lonely or Happy When by Yourself?</a> <br> <a href="https://theweedblog.com/industry/terpene-buyer-s-guide" title="Terpene Buyer's Guide">Terpene Buyer's Guide</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-dank-box-weed-brownies" title="How To Make Dank Box Weed Brownies">How To Make Dank Box Weed Brownies</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/superman-og-marijuana-strain-review-and-pictures" title="Superman OG Marijuana Strain Review And Pictures">Superman OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/getting-that-perfect-dry-trim-for-your-cannabis" title="Getting that Perfect Dry Trim for your Cannabis">Getting that Perfect Dry Trim for your Cannabis</a> <br> <a href="https://theweedblog.com/growing/how-to-avoid-weak-marijuana-seedlings" title="How To Avoid Weak Marijuana Seedlings">How To Avoid Weak Marijuana Seedlings</a> <br> <a href="https://theweedblog.com/science/empathy-vs-apathy-in-cannabis-users" title="Empathy vs Apathy in Cannabis Users">Empathy vs Apathy in Cannabis Users</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-much-should-a-twenty-sack-or-dub-weigh" title="How Many Grams Is a Dub of Weed? | Weight of a 20 Sack of Weed | Marijuana News and Facts">How Many Grams Is a Dub of Weed? | Weight of a 20 Sack of Weed | Marijuana News and Facts</a> <br> <a href="https://theweedblog.com/growing/the-structure-and-function-of-stomata-on-a-marijuana-leaf" title="Stomata On A Marijuana Leaf">Stomata On A Marijuana Leaf</a> <br> <a href="https://theweedblog.com/growing/is-it-better-to-grow-marijuana-hydroponically-or-in-soil" title="Is It Better To Grow Marijuana Hydroponically Or In Soil?">Is It Better To Grow Marijuana Hydroponically Or In Soil?</a> <br> <a href="https://theweedblog.com/policies/will-new-york-legalize-weed-2020" title="Will New York Finally Legalize Weed in 2020?">Will New York Finally Legalize Weed in 2020?</a> <br> <a href="https://theweedblog.com/marijuana-science/get-high-from-fail-drug-test-secondhand-marijuana-smoke" title="Can Secondhand Marijuana Smoke Make You Fail a Drug Test?| Facts About THC">Can Secondhand Marijuana Smoke Make You Fail a Drug Test?| Facts About THC</a> <br> <a href="https://theweedblog.com/policies/bill-legalize-medical-marijuana-approved-kentucky-house" title="Bill to Legalize Medical Marijuana Overwhelmingly Approved by Kentucky House Committee">Bill to Legalize Medical Marijuana Overwhelmingly Approved by Kentucky House Committee</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/julius-caesar-marijuana-strain-review-and-pictures" title="Julius Caesar Marijuana Strain Review And Pictures">Julius Caesar Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/afghan-og-strain-review" title="Afghan OG Strain Review">Afghan OG Strain Review</a> <br> <a href="https://theweedblog.com/culture/understanding-the-rick-morty-bong-craze" title="Understanding Rick &amp; Morty Bongs">Understanding Rick &amp; Morty Bongs</a> <br> <a href="https://theweedblog.com/culture/fun-things-for-stoners-to-do-during-covid-19-pandemic" title="Fun Things for Stoners to do During the COVID-19 Pandemic">Fun Things for Stoners to do During the COVID-19 Pandemic</a> <br> <a href="https://theweedblog.com/marijuana-science/does-marijuana-cure-an-alcohol-hangover" title="Does Marijuana Cure An Alcohol Hangover? - The Weed Blog">Does Marijuana Cure An Alcohol Hangover? - The Weed Blog</a> <br> <a href="https://theweedblog.com/culture/tips-successful-wake-bake" title="Wake and Bake: Tips for a Success - The Weed Blog">Wake and Bake: Tips for a Success - The Weed Blog</a> <br> <a href="https://theweedblog.com/growing/marijuana-plant-nutrient-deficiency-calcium" title="Marijuana Plant Nutrient Deficiency - Calcium">Marijuana Plant Nutrient Deficiency - Calcium</a> <br> <a href="https://theweedblog.com/growing/led-grow-lights-3-watt-vs-5-watt-vs-10-watt" title="LED Grow Lights - 3 Watt Vs. 5 Watt Vs. 10 Watt">LED Grow Lights - 3 Watt Vs. 5 Watt Vs. 10 Watt</a> <br> <a href="https://theweedblog.com/culture/top-stoner-holiday-gifts-2019" title="Top 6 Stoner-iffic Holiday Gifts for 2019">Top 6 Stoner-iffic Holiday Gifts for 2019</a> <br> <a href="https://theweedblog.com/medical/high-intensity-workouts-using-cbd-to-combat-the-effects-of-cortisol" title="High-Intensity Workouts: Using CBD to Combat the Effects of Cortisol">High-Intensity Workouts: Using CBD to Combat the Effects of Cortisol</a> <br> <a href="https://theweedblog.com/science/the-complicated-relationship-between-cannabis-memories-and-nostalgia" title="The complicated relationship between cannabis">The complicated relationship between cannabis</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-spot-the-differences-between-indica-sativa" title="How to Spot the Differences Between Indica &amp; Sativa">How to Spot the Differences Between Indica &amp; Sativa</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-can-you-tell-when-its-time-to-harvest" title="How Can You Tell When Its Time To Harvest?">How Can You Tell When Its Time To Harvest?</a> <br> <a href="https://theweedblog.com/growing/clone-your-outdoor-marijuana-plants" title="Clone Your Outdoor Marijuana Plants">Clone Your Outdoor Marijuana Plants</a> <br> <a href="https://theweedblog.com/growing/how-to-make-your-own-marijuana-seeds" title="How To Make Your Own Marijuana Seeds">How To Make Your Own Marijuana Seeds</a> <br> <a href="https://theweedblog.com/growing/growing-cannabis-in-tight-spaces" title="Growing Cannabis in Tight Spaces">Growing Cannabis in Tight Spaces</a> <br> <a href="https://theweedblog.com/growing/5-steps-for-setting-up-an-efficient-grow-room" title="5 Steps for setting up an efficient grow room">5 Steps for setting up an efficient grow room</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/diamond-og-marijuana-strain-review-and-pictures" title="Diamond OG Marijuana Strain Review And Pictures">Diamond OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/how-to-increase-terpenes-when-growing-your-cannabis-plants" title="How to Increase Terpenes When Growing Your Cannabis Plants">How to Increase Terpenes When Growing Your Cannabis Plants</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/champagne-marijuana-strain-review-and-pictures" title="Champagne Marijuana Strain Review And Pictures">Champagne Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/how-to-fix-the-problem-of-long-stretchy-stems-on-marijuana-seedlings" title="How To Fix The Problem Of Long">How To Fix The Problem Of Long</a> <br> <a href="https://theweedblog.com/advocacy/athens-cannabis-club" title="Athens Cannabis Club">Athens Cannabis Club</a> <br> <a href="https://theweedblog.com/growing/how-to-protect-your-outdoor-marijuana-plants-from-mammals-and-rodents" title="How To Protect Your Outdoor Marijuana Plants From Mammals And Rodents">How To Protect Your Outdoor Marijuana Plants From Mammals And Rodents</a> <br> <a href="https://theweedblog.com/growing/how-hydroponics-and-led-grow-lights-exploded-my-cannabis-grow-by-20" title="How Hydroponics and LED Grow Lights Exploded My Cannabis Grow By 20%">How Hydroponics and LED Grow Lights Exploded My Cannabis Grow By 20%</a> <br> <a href="https://theweedblog.com/growing/know-when-to-harvest-like-a-pro" title="Know When to Harvest Like a Pro">Know When to Harvest Like a Pro</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/black-domina-marijuana-strain-review-and-pictures" title="Black Domina Marijuana Strain Review And Pictures">Black Domina Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/ending-marijuana-prohibition/how-to-be-a-marijuana-dealer-growing-your-business" title="How to Be a Marijuana Dealer â€” Growing Your Business">How to Be a Marijuana Dealer â€” Growing Your Business</a> <br> <a href="https://theweedblog.com/growing/identify-marijuana-leaf-issues" title="How to Identify Marijuana Leaf Issues and Their Common Causes">How to Identify Marijuana Leaf Issues and Their Common Causes</a> <br> <a href="https://theweedblog.com/growing/how-ants-can-damage-your-marijuana-plants" title="How Ants Can Damage Your Marijuana Plants">How Ants Can Damage Your Marijuana Plants</a> <br> <a href="https://theweedblog.com/guides/how-many-grams-ounce-weed" title="How Many Grams to an Ounce of Weed?">How Many Grams to an Ounce of Weed?</a> <br> <a href="https://theweedblog.com/growing/what-is-the-best-ph-level-for-marijuana-plants" title="What Is The Best PH Level For Marijuana Plants?">What Is The Best PH Level For Marijuana Plants?</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-survive-a-rental-property-inspection-when-you-grow-marijuana" title="How To Survive A Rental Property Inspection When You Grow Marijuana">How To Survive A Rental Property Inspection When You Grow Marijuana</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/does-holding-in-a-hit-of-marijuana-longer-make-you-higher" title="Higher By Holding In A Hit Of Marijuana Longer">Higher By Holding In A Hit Of Marijuana Longer</a> <br> <a href="https://theweedblog.com/medical/carrier-oils-in-cannabis-what-is-best-for-you" title="Carrier Oils in Cannabis â€“ What is Best for You?">Carrier Oils in Cannabis â€“ What is Best for You?</a> <br> <a href="https://theweedblog.com/medical-marijuana-policy/marijuana-and-gastrointestinal-disorders" title="Marijuana And Gastrointestinal Disorders">Marijuana And Gastrointestinal Disorders</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-tell-if-marijuana-dabs-are-good-or-bad" title="How To Tell If Marijuana Dabs Are Good Or Bad">How To Tell If Marijuana Dabs Are Good Or Bad</a> <br> <a href="https://theweedblog.com/growing/how-to-identify-and-treat-yellow-leaf-spots-on-marijuana-plants" title="How To Identify And Treat Yellow Leaf Spots On Marijuana Plants">How To Identify And Treat Yellow Leaf Spots On Marijuana Plants</a> <br> <a href="https://theweedblog.com/medical-marijuana-policy/does-medical-marijuana-help-treat-diarrhea" title="Does Medical Marijuana Help Treat Diarrhea">Does Medical Marijuana Help Treat Diarrhea</a> <br> <a href="https://theweedblog.com/policies/100-most-cannabis-friendly-countries" title="The 100 Most-Visited Countries in the World Ranked by Their Cannabis Friendliness">The 100 Most-Visited Countries in the World Ranked by Their Cannabis Friendliness</a> <br> <a href="https://theweedblog.com/growing/when-and-how-to-prune-marijuana-plants" title="When And How To Prune Marijuana Plants">When And How To Prune Marijuana Plants</a> <br> <a href="https://theweedblog.com/growing/what-is-the-best-ph-and-ec-levels-for-hydro-marijuana-growers" title="What Is The Best pH And EC Levels For Hydro Marijuana Growers?">What Is The Best pH And EC Levels For Hydro Marijuana Growers?</a> <br> <a href="https://theweedblog.com/culture/the-top-10-gifts-for-your-stoner-sweetie-on-valentine-s-day-2018" title="The Top 10 Gifts for your Stoner Sweetie on Valentineâ€™s Day 2018">The Top 10 Gifts for your Stoner Sweetie on Valentineâ€™s Day 2018</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/have-you-ever-burped-marijuana-smoke" title="Have You Ever Burped Marijuana Smoke?">Have You Ever Burped Marijuana Smoke?</a> <br> <a href="https://theweedblog.com/growing/how-much-marijuana-does-a-marijuana-plant-yield" title="Marijuana Plant Yield Can Depend on Many Variables - The Weed Blog">Marijuana Plant Yield Can Depend on Many Variables - The Weed Blog</a> <br> <a href="https://theweedblog.com/culture/the-proper-way-to-dispose-of-old-e-cig-and-vape-batteries" title="The Proper Way to Dispose Of Old E-Cig and Vape Batteries">The Proper Way to Dispose Of Old E-Cig and Vape Batteries</a> <br> <a href="https://theweedblog.com/medical/best-9-marijuana-strains-for-back-pain" title="Best 9 Marijuana Strains For Back Pain">Best 9 Marijuana Strains For Back Pain</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-much-marijuana-do-you-get-in-your-area-for-20" title="How Much Marijuana Do You Get In Your Area For $20?">How Much Marijuana Do You Get In Your Area For $20?</a> <br> <a href="https://theweedblog.com/growing/how-to-grow-dense-and-bushy-marijuana-plants" title="How To Grow Dense And Bushy Marijuana Plants">How To Grow Dense And Bushy Marijuana Plants</a> <br> <a href="https://theweedblog.com/growing/how-to-collect-marijuana-pollen-and-use-it" title="How To Collect Marijuana Pollen And Use It">How To Collect Marijuana Pollen And Use It</a> <br> <a href="https://theweedblog.com/growing/the-best-most-popular-marijuana-fertilizers" title="Fertilizers: The Most Popular for Marijuana Growing - The Weed Blog">Fertilizers: The Most Popular for Marijuana Growing - The Weed Blog</a> <br> <a href="https://theweedblog.com/growing/advantages-of-feminised-seeds-vs-auto-flowering-seeds-for-indoor-cultivation" title="Advantages Of Feminised Seeds vs. Auto flowering Seeds For Indoor Cultivation">Advantages Of Feminised Seeds vs. Auto flowering Seeds For Indoor Cultivation</a> <br> <a href="https://theweedblog.com/growing/the-healthiest-ways-to-get-high" title="The Healthiest Ways to Get High">The Healthiest Ways to Get High</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/can-you-smoke-resin" title="Does Smoking Resin Get You High? | How to Smoke Resin From a Bowl | Tips for Smoking Marijuana Resin">Does Smoking Resin Get You High? | How to Smoke Resin From a Bowl | Tips for Smoking Marijuana Resin</a> <br> </span></p></div><span style="color: #444;">•</span><div class="nav-category inline"> <input type="checkbox" class="read-more-state" id="collapse-cat-1"> <label for="collapse-cat-1" class="read-more-trigger">Cannabis Information</label><p class="read-more-wrap"> <span class="read-more-target"> <a href="https://theweedblog.com/marijuana-strain-reviews/bubblegum-marijuana-strain-review-and-pictures" title="Bubblegum Marijuana Strain Review And Pictures">Bubblegum Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-the-perfect-marijuana-candy" title="How To Make The Perfect Marijuana Candy">How To Make The Perfect Marijuana Candy</a> <br> <a href="https://theweedblog.com/opinion/do-people-smoke-more-marijuana-in-the-summer" title="Do People Smoke More Marijuana In The Summer">Do People Smoke More Marijuana In The Summer</a> <br> <a href="https://theweedblog.com/medical-marijuana-policy/how-to-get-a-medical-marijuana-card-in-washington-state" title="How To Get A Medical Marijuana Card In Washington State">How To Get A Medical Marijuana Card In Washington State</a> <br> <a href="https://theweedblog.com/hemp-info/arguments-against-hemp-and-why-they-are-wrong" title="Arguments Against Hemp And Why They Are Wrong">Arguments Against Hemp And Why They Are Wrong</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/blue-crack-marijuana-strain-review-and-pictures" title="Blue Crack Marijuana Strain Review And Pictures">Blue Crack Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/culture/smoking-gun-vietnam-soldiers-got-stoned" title="Smoking Gun: How Vietnam Soldiers Got Stoned - The Weed Blog">Smoking Gun: How Vietnam Soldiers Got Stoned - The Weed Blog</a> <br> <a href="https://theweedblog.com/science/a-tale-of-two-strains-indica-and-sativa" title="A Tale Of Two Strains: Indica and Sativa">A Tale Of Two Strains: Indica and Sativa</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/platinum-kush-marijuana-strain-review-and-pictures" title="Platinum Kush Marijuana Strain Review And Pictures">Platinum Kush Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-pics/pez-marijuana-strain-review-and-pictures" title="Pez Marijuana Strain Review And Pictures">Pez Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/ending-marijuana-prohibition/getting-the-most-of-your-terps" title="Getting the Most of Your Terps">Getting the Most of Your Terps</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/lemon-diesel-marijuana-strain-review-and-pictures" title="Lemon Diesel Marijuana Strain Review And Pictures">Lemon Diesel Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/eclipse-farm-ecology-mana-gooey-marijuana-bho-review" title="Eclipse Farm-Ecology Mana Gooey Marijuana BHO Review">Eclipse Farm-Ecology Mana Gooey Marijuana BHO Review</a> <br> <a href="https://theweedblog.com/growing/what-is-the-best-marijuana-grow-light-setup-for-an-indoor-garden" title="What Is The Best Marijuana Grow Light Setup For An Indoor Garden?">What Is The Best Marijuana Grow Light Setup For An Indoor Garden?</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-chocolate-marijuana-cupcakes" title="How To Make Chocolate Marijuana Cupcakes">How To Make Chocolate Marijuana Cupcakes</a> <br> <a href="https://theweedblog.com/industry/ceo-interview-adam-berk-the-vision-behind-stem-holdings" title="CEO Interview: Adam Berk">CEO Interview: Adam Berk</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/blueberry-haze-marijuana-strain-review-and-pictures" title="Blueberry Haze Marijuana Strain Review And Pictures">Blueberry Haze Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/platinum-og-marijuana-strain-review-and-pictures" title="Platinum OG Marijuana Strain Review And Pictures">Platinum OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/berry-white-marijuana-strain-review-and-pictures" title="Berry White Marijuana Strain Review And Pictures">Berry White Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/davinci-miqro-vaporizer-review" title="Davinci MIQRO Vaporizer Review">Davinci MIQRO Vaporizer Review</a> <br> <a href="https://theweedblog.com/marijuana-pics/dr-og-kush-marijuana-strain-pictures" title="Dr. Og Kush Marijuana Strain Pictures">Dr. Og Kush Marijuana Strain Pictures</a> <br> <a href="https://theweedblog.com/culture/5-marijuana-strains-for-depression-and-nervousness" title="5 Marijuana Strains for Depression and Nervousness">5 Marijuana Strains for Depression and Nervousness</a> <br> <a href="https://theweedblog.com/culture/concentrate-review-papaya-live-resin-viola" title="Concentrate Review: Papaya Live Resin by Viola">Concentrate Review: Papaya Live Resin by Viola</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-marijuana-smores" title="How To Make Marijuana S'mores">How To Make Marijuana S'mores</a> <br> <a href="https://theweedblog.com/growing/a-semi-portable-vaporizer-that-is-totally-new-ground-up" title="A semi-portable vaporizer that is totally new ground up">A semi-portable vaporizer that is totally new ground up</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/why-super-silver-haze-is-one-of-the-most-popular-marijuana-strains" title="Why Super Silver Haze Is One Of The Most Popular Marijuana Strains">Why Super Silver Haze Is One Of The Most Popular Marijuana Strains</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/hogs-breath-marijuana-strain-review-and-pictures" title="Hogs Breath Marijuana Strain Review And Pictures">Hogs Breath Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/policies/the-war-on-drugs-mexico-will-legalize-before-united-states" title="Mexico Will Legalize Before United States">Mexico Will Legalize Before United States</a> <br> <a href="https://theweedblog.com/medical/how-to-deal-with-the-side-effects-of-medical-marijuana" title="How to Deal With the Side Effects of Medical Marijuana">How to Deal With the Side Effects of Medical Marijuana</a> <br> <a href="https://theweedblog.com/ending-marijuana-prohibition/have-you-ever-seen-a-chong-bong" title="Have You Ever Seen A Chong Bong?">Have You Ever Seen A Chong Bong?</a> <br> <a href="https://theweedblog.com/growing/get-your-free-copy-of-the-marijuana-grow-bible" title="Get Your FREE Copy Of The Marijuana Grow Bible Right Now!">Get Your FREE Copy Of The Marijuana Grow Bible Right Now!</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/purple-haze-marijuana-strain-review-and-pictures" title="Purple Haze Marijuana Strain Review And Pictures">Purple Haze Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/goji-og-marijuana-strain-review-and-pictures" title="Goji OG Marijuana Strain Review And Pictures">Goji OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/the-ultimate-cannabutter-experiment" title="The Ultimate Cannabutter Experiment">The Ultimate Cannabutter Experiment</a> <br> <a href="https://theweedblog.com/ending-marijuana-prohibition/how-to-stay-out-of-trouble-while-driving-with-marijuana" title="How To Stay Out Of Trouble While Driving With Marijuana">How To Stay Out Of Trouble While Driving With Marijuana</a> <br> <a href="https://theweedblog.com/growing/how-to-deal-with-stretching-marijuana-plants" title="How To Deal With Stretching Marijuana Plants">How To Deal With Stretching Marijuana Plants</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/purple-urkle-marijuana-strain-review-and-pictures" title="Purple Urkle Marijuana Strain Review And Pictures">Purple Urkle Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/hydro-marijuana-growing-better-to-use-a-reservoir-or-drip-system" title="Hydro Marijuana Growing - Better To Use A Reservoir Or Drip System?">Hydro Marijuana Growing - Better To Use A Reservoir Or Drip System?</a> <br> <a href="https://theweedblog.com/growing/subcool-super-soil-recipe" title="Subcool Super Soil Recipe">Subcool Super Soil Recipe</a> <br> <a href="https://theweedblog.com/policies/norway-decriminalizes-lsd" title="Norway Decriminalizes LSD">Norway Decriminalizes LSD</a> <br> <a href="https://theweedblog.com/policies/missouri-seeks-adult-use-marijuana-2020-ballot" title="Missouri Seeks to Place Adult-Use Marijuana on 2020 Ballot">Missouri Seeks to Place Adult-Use Marijuana on 2020 Ballot</a> <br> <a href="https://theweedblog.com/growing/how-to-recognize-iron-deficiencies-on-marijuana-plants" title="How To Recognize Iron Deficiencies On Marijuana Plants">How To Recognize Iron Deficiencies On Marijuana Plants</a> <br> <a href="https://theweedblog.com/marijuana-entertainment/how-to-make-a-coconut-bong" title="How To Make A Coconut Bong">How To Make A Coconut Bong</a> <br> <a href="https://theweedblog.com/culture/how-to-explain-cbd-oil-to-your-mom" title="How to Explain CBD Oil to Your Mom">How to Explain CBD Oil to Your Mom</a> <br> <a href="https://theweedblog.com/growing/what-to-do-to-keep-caterpillars-off-your-marijuana-plants" title="What To Do To Keep Caterpillars Off Your Marijuana Plants">What To Do To Keep Caterpillars Off Your Marijuana Plants</a> <br> <a href="https://theweedblog.com/growing/how-understanding-vapor-pressure-deficit-will-improve-your-grow" title="How Understanding Vapor Pressure Deficit will Improve your Grow">How Understanding Vapor Pressure Deficit will Improve your Grow</a> <br> <a href="https://theweedblog.com/marijuana-products/5-reason-stoners-should-embrace-pokemon-go" title="5 Reason Stoners Should Embrace Pokemon Go">5 Reason Stoners Should Embrace Pokemon Go</a> <br> <a href="https://theweedblog.com/medical-marijuana-policy/cannabis-and-muscle-spasms" title="Cannabis And Muscle Spasms">Cannabis And Muscle Spasms</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/is-marijuana-a-weed" title="Is Marijuana A Weed?">Is Marijuana A Weed?</a> <br> <a href="https://theweedblog.com/medical/uncovering-the-uncommon-commonalities-between-covid-19-and-evali" title="Uncovering the Uncommon: Commonalities Between COVID-19 and EVALI">Uncovering the Uncommon: Commonalities Between COVID-19 and EVALI</a> <br> <a href="https://theweedblog.com/culture/product-review-the-kettle-by-ooze" title="The Kettle by Ooze Review">The Kettle by Ooze Review</a> <br> <a href="https://theweedblog.com/growing/what-happens-when-you-underwater-your-marijuana-plants" title="What Happens When You Underwater Your Marijuana Plants?">What Happens When You Underwater Your Marijuana Plants?</a> <br> <a href="https://theweedblog.com/growing/top-five-things-to-consider-when-buying-cannabis-grow-lights" title="Top Five Things to Consider When Buying Cannabis Grow Lights">Top Five Things to Consider When Buying Cannabis Grow Lights</a> <br> <a href="https://theweedblog.com/growing/how-to-setup-an-indoor-marijuana-garden-on-a-budget" title="Marijuana Garden and How To Setup Indoors - The Weeb Blog">Marijuana Garden and How To Setup Indoors - The Weeb Blog</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/five-things-you-may-not-want-to-do-while-stoned" title="Five Things You May Not Want To Do While Stoned">Five Things You May Not Want To Do While Stoned</a> <br> <a href="https://theweedblog.com/medical/medical-marijuana-users-new-jersey-cant-be-fired-for-failing-drug-test" title="Medical Marijuana Users in New Jersey Can't be Fired for Failing a Drug Test">Medical Marijuana Users in New Jersey Can't be Fired for Failing a Drug Test</a> <br> <a href="https://theweedblog.com/growing/distribution-of-sugars-within-marijuana-plants" title="Distribution Of Sugars Within Marijuana Plants">Distribution Of Sugars Within Marijuana Plants</a> <br> <a href="https://theweedblog.com/opinion/what-is-marijuana-butane-hash-oil-bho-and-is-it-safe" title="What Is Marijuana Butane Hash Oil (BHO) And Is It Safe?">What Is Marijuana Butane Hash Oil (BHO) And Is It Safe?</a> <br> <a href="https://theweedblog.com/drug-testing/plan-on-cheating-on-a-drug-test-for-weed-think-again-its-not-worth-it" title="Cheating on a Drug Test? - Think Again - The Weed Blog">Cheating on a Drug Test? - Think Again - The Weed Blog</a> <br> <a href="https://theweedblog.com/cooking/pumpkin-spice-meets-cannabis-in-these-4-seasonal-recipes" title="Pumpkin Spice Meets Cannabis in these 4 Seasonal Recipes">Pumpkin Spice Meets Cannabis in these 4 Seasonal Recipes</a> <br> <a href="https://theweedblog.com/advocacy/the-10-biggest-reasons-support-for-marijuana-legalization-will-continue-to-rise" title="The 10 Biggest Reasons Support for Marijuana Legalization will Continue to Rise">The 10 Biggest Reasons Support for Marijuana Legalization will Continue to Rise</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-marijuana-bread" title="How To Make Marijuana Bread">How To Make Marijuana Bread</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-get-free-marijuana-and-marijuana-products" title="How To Get Free Marijuana And Marijuana Products">How To Get Free Marijuana And Marijuana Products</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/blue-dream-marijuana-strain-review-and-pictures" title="Blue Dream Marijuana Strain Review And Pictures">Blue Dream Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/culture/cannabolish-the-ultimate-canna-hero-odor-eliminator" title="Cannabolish: The Ultimate Canna-Hero Odor Eliminator">Cannabolish: The Ultimate Canna-Hero Odor Eliminator</a> <br> <a href="https://theweedblog.com/marijuana-pics/captain-america-marijuana-strain-pictures" title="Captain America Marijuana Strain Pictures">Captain America Marijuana Strain Pictures</a> <br> <a href="https://theweedblog.com/culture/not-all-grinders-are-created-equal-green-monkey-grinders" title="Not All Grinders are Created Equal">Not All Grinders are Created Equal</a> <br> <a href="https://theweedblog.com/marijuana-pics/exotic-berry-marijuana-strain-pictures" title="Exotic Berry Marijuana Strain Pictures">Exotic Berry Marijuana Strain Pictures</a> <br> <a href="https://theweedblog.com/growing/how-to-get-rid-of-whiteflies-on-your-marijuana-plants" title="How To Get Rid Of Whiteflies On Your Marijuana Plants">How To Get Rid Of Whiteflies On Your Marijuana Plants</a> <br> <a href="https://theweedblog.com/culture/dabbing-with-the-dipper" title="Dabbing with the Dipper!">Dabbing with the Dipper!</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/alien-og-marijuana-strain-review-and-pictures" title="Alien OG Marijuana Strain Review And Pictures">Alien OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/highest-testing-cbd-strain-from-yerba-buena-farms-in-oregon" title="Highest Testing CBD Strain from Yerba Buena Farms in Oregon">Highest Testing CBD Strain from Yerba Buena Farms in Oregon</a> <br> <a href="https://theweedblog.com/growing/pruning-marijuana-plants" title="Pruning Marijuana Plants - Growing Marijuana on The Weed Blog">Pruning Marijuana Plants - Growing Marijuana on The Weed Blog</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/bloom-kush-marijuana-strain-review" title="Bloom Kush Marijuana Strain Review">Bloom Kush Marijuana Strain Review</a> <br> <a href="https://theweedblog.com/content-partner/5-steps-perfecting-grow-room-climate-control" title="5 Steps to Perfecting Grow Room Climate Control">5 Steps to Perfecting Grow Room Climate Control</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/jedi-marijuana-strain-review-and-pictures" title="Jedi Marijuana Strain Review And Pictures">Jedi Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/ounce-of-prevention-how-to-avoid-powdery-mildew-on-a-cannabis-grow" title="Ounce of Prevention: How to avoid powdery mildew on a cannabis grow">Ounce of Prevention: How to avoid powdery mildew on a cannabis grow</a> <br> <a href="https://theweedblog.com/culture/the-concept-and-lady-bosses-behind-the-newest-girly-vape-pen-the-bae" title="The Concept and Lady Bosses Behind the Newest Girly Vape Pen: The Bae">The Concept and Lady Bosses Behind the Newest Girly Vape Pen: The Bae</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/white-widow-is-one-of-the-most-popular-marijuana-strains-of-all-time" title="White Widow Is One Of The Most Popular Marijuana Strains Of All Time">White Widow Is One Of The Most Popular Marijuana Strains Of All Time</a> <br> <a href="https://theweedblog.com/marijuana-science/terpenes" title="What are Terpenes in Marijuana? - The Weed Blog">What are Terpenes in Marijuana? - The Weed Blog</a> <br> <a href="https://theweedblog.com/growing/how-to-grow-the-blueberry-marijuana-strain-indoors" title="How To Grow The Blueberry Marijuana Strain Indoors">How To Grow The Blueberry Marijuana Strain Indoors</a> <br> <a href="https://theweedblog.com/growing/what-are-the-best-ph-and-ec-levels-for-marijuana-plants" title="What Are The Best PH And EC Levels For Marijuana Plants?">What Are The Best PH And EC Levels For Marijuana Plants?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/true-og-marijuana-strain-review-and-pictures" title="True OG Marijuana Strain Review And Pictures">True OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/how-does-lighting-affect-your-marijuana-yield" title="How Does Lighting Affect Your Marijuana Yield?">How Does Lighting Affect Your Marijuana Yield?</a> <br> <a href="https://theweedblog.com/growing/how-to-grow-the-amnesia-haze-marijuana-strain-indoors" title="How To Grow The Amnesia Haze Marijuana Strain Indoors">How To Grow The Amnesia Haze Marijuana Strain Indoors</a> <br> <a href="https://theweedblog.com/growing/the-top-5-marijuana-strains-for-beginning-growers" title="The Top 5 Marijuana Strains for Beginning Growers">The Top 5 Marijuana Strains for Beginning Growers</a> <br> <a href="https://theweedblog.com/culture/best-valentines-gifts-for-stoners-2020" title="The Best Valentine's Gifts for Stoners in 2020">The Best Valentine's Gifts for Stoners in 2020</a> <br> <a href="https://theweedblog.com/ending-marijuana-prohibition/how-can-you-tell-if-your-marijuana-comes-from-a-cartel" title="How Can You Tell If Your Marijuana Comes From A Cartel?">How Can You Tell If Your Marijuana Comes From A Cartel?</a> <br> <a href="https://theweedblog.com/culture/introducing-tangos-lunchbox-alchemy-s-cannabis-infused-sour-fruit-bites" title="Introducing Tangos - Lunchbox Alchemyâ€™s Cannabis-Infused Sour Fruit Bites">Introducing Tangos - Lunchbox Alchemyâ€™s Cannabis-Infused Sour Fruit Bites</a> <br> <a href="https://theweedblog.com/growing/how-to-quickly-dry-your-marijuana-plants" title="How To Quickly Dry Your Marijuana Plants">How To Quickly Dry Your Marijuana Plants</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/4-tips-to-save-money-on-weed" title="4 Tips To Save Money On Weed">4 Tips To Save Money On Weed</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/northern-lights-cannabis-strain-review-and-pictures" title="Northern Lights Cannabis Strain Review And Pictures">Northern Lights Cannabis Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/tutorial-feeding-your-cannabis-plants-nutrients" title="Tutorial: Feeding Your Cannabis Plants Nutrients">Tutorial: Feeding Your Cannabis Plants Nutrients</a> <br> <a href="https://theweedblog.com/cooking/4-vegan-edible-recipes-you-will-love" title="4 Vegan Edible Recipes You Will Love">4 Vegan Edible Recipes You Will Love</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-clean-a-marijuana-vaporizer-bag" title="How to Clean a Marijuana Vaporizer Bag">How to Clean a Marijuana Vaporizer Bag</a> <br> <a href="https://theweedblog.com/medical-marijuana-policy/how-to-get-a-medical-marijuana-card-in-rhode-island" title="How To Get A Medical Marijuana Card In Rhode Island">How To Get A Medical Marijuana Card In Rhode Island</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/og-kush-cannabis-strain-review-and-pictures" title="OG Kush Cannabis Strain Review And Pictures">OG Kush Cannabis Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/how-to-get-rid-of-pests-and-bugs-on-marijuana-plants" title="How To Get Rid Of Pests And Bugs On Marijuana Plants">How To Get Rid Of Pests And Bugs On Marijuana Plants</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/ogre-og-marijuana-strain-review-and-pictures" title="Ogre OG Marijuana Strain Review And Pictures">Ogre OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/medical/how-does-marijuana-affect-blood-pressure" title="How Does Marijuana Affect Blood Pressure?">How Does Marijuana Affect Blood Pressure?</a> <br> <a href="https://theweedblog.com/content-partner/10-reasons-why-it-pays-to-grow-pot-with-hydroponics" title="10 Reasons Why it Pays to Grow Pot with Hydroponics">10 Reasons Why it Pays to Grow Pot with Hydroponics</a> <br> <a href="https://theweedblog.com/marijuana-entertainment/marijuana-world-records" title="Marijuana World Records">Marijuana World Records</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/blueberry-gum-marijuana-strain-pictures-and-review" title="Blueberry Gum Marijuana Strain Pictures And Review">Blueberry Gum Marijuana Strain Pictures And Review</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/kryptonite-og-cannabis-strain-review-and-pictures" title="Kryptonite OG Cannabis Strain Review And Pictures">Kryptonite OG Cannabis Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/top-ten-rookie-mistakes-to-avoid-when-growing-marijuana" title="Top Ten Rookie Mistakes To Avoid When Growing Marijuana">Top Ten Rookie Mistakes To Avoid When Growing Marijuana</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/granddaddy-purple-marijuana-strain-review-and-pictures" title="Granddaddy Purple Marijuana Strain Review And Pictures">Granddaddy Purple Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/culture/dab-rig-vaporizers-2019" title="Dab Rig Vaporizers of 2019">Dab Rig Vaporizers of 2019</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/holy-grail-og-marijuana-strain-review-and-pictures" title="Holy Grail OG Marijuana Strain Review And Pictures">Holy Grail OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/harvest-marijuana-plants" title="Harvest Marijuana Plants: When And How To Harvest">Harvest Marijuana Plants: When And How To Harvest</a> <br> <a href="https://theweedblog.com/growing/optilux-led-grow-light-the-most-powerful-light-in-the-world" title="Optilux LED Grow Light: The most powerful light in the world?">Optilux LED Grow Light: The most powerful light in the world?</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/ten-stoner-life-hacks" title="Ten Stoner Life Hacks">Ten Stoner Life Hacks</a> <br> <a href="https://theweedblog.com/industry/cannabis-vs-botanical-terpenes-from-a-business-perspective" title="Cannabis vs. Botanical Terpenes from a Business Perspective">Cannabis vs. Botanical Terpenes from a Business Perspective</a> <br> <a href="https://theweedblog.com/growing/growing-cannabis-in-coir" title="Adventures in Growing Cannabis in Coir">Adventures in Growing Cannabis in Coir</a> <br> <a href="https://theweedblog.com/growing/this-is-how-you-create-strong-marijuana-plants" title="This Is How You Create Strong Marijuana Plants">This Is How You Create Strong Marijuana Plants</a> <br> <a href="https://theweedblog.com/industry/frenchy-cannoli-legendary-hashish-master" title="Frenchy Cannoli: Legendary Hashish Master">Frenchy Cannoli: Legendary Hashish Master</a> <br> <a href="https://theweedblog.com/growing/how-to-grow-marijuana-in-desert-heat" title="How To Grow Marijuana In Desert Heat">How To Grow Marijuana In Desert Heat</a> <br> <a href="https://theweedblog.com/growing/what-to-do-when-your-marijuana-plants-wont-flower" title="What To Do When Your Marijuana Plants Won't Flower">What To Do When Your Marijuana Plants Won't Flower</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-crutch-a-joint" title="How To Crutch A Joint">How To Crutch A Joint</a> <br> <a href="https://theweedblog.com/medical-marijuana-policy/mangos-increase-the-effects-of-consuming-marijuana" title="Mangoes Increase The Effects Of Consuming Marijuana">Mangoes Increase The Effects Of Consuming Marijuana</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/black-jack-marijuana-strain-review-and-pictures" title="Black Jack Marijuana Strain Review And Pictures">Black Jack Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/medical/can-medical-marijuana-help-relieve-tinnitus" title="Can Medical Marijuana Help Relieve Tinnitus?">Can Medical Marijuana Help Relieve Tinnitus?</a> <br> <a href="https://theweedblog.com/growing/how-to-pick-a-properly-sized-indoor-grow-tent" title="How to Pick a Properly Sized Indoor Grow Tent">How to Pick a Properly Sized Indoor Grow Tent</a> <br> <a href="https://theweedblog.com/growing/marijuana-butter-oil-milk-marijuana-plant-trim" title="Make Marijuana Butter">Make Marijuana Butter</a> <br> <a href="https://theweedblog.com/medical/can-medical-marijuana-be-used-to-treat-back-pain" title="Can Medical Marijuana be Used to Treat Back Pain?">Can Medical Marijuana be Used to Treat Back Pain?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/cherry-pie-og-marijuana-strain-review-and-pictures" title="Cherry Pie OG Marijuana Strain Review And Pictures">Cherry Pie OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/ghost-og-marijuana-strain-review-and-pictures" title="Ghost OG Marijuana Strain Review And Pictures">Ghost OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/how-to-get-rid-of-aphids-on-your-marijuana-plants" title="How To Get Rid Of Aphids On Your Marijuana Plants">How To Get Rid Of Aphids On Your Marijuana Plants</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/black-label-kush-marijuana-strain-review-and-pictures" title="Black Label Kush Marijuana Strain Review And Pictures">Black Label Kush Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/culture/marijuana-products-weed-tinctures" title="Tinctures: What are They and How to Make Them - The Weed Blog">Tinctures: What are They and How to Make Them - The Weed Blog</a> <br> <a href="https://theweedblog.com/culture/focus-v-carta-vaporizer-review" title="Focus V Carta Vaporizer">Focus V Carta Vaporizer</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/darth-vader-marijuana-strain-review-and-pictures" title="Darth Vader Marijuana Strain Review And Pictures">Darth Vader Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/medical/10-diseases-that-can-be-treated-using-cannabis" title="10 Diseases That Can Be Treated Using Cannabis">10 Diseases That Can Be Treated Using Cannabis</a> <br> <a href="https://theweedblog.com/growing/how-much-light-do-outdoor-marijuana-plants-need" title="How Much Light Do Outdoor Marijuana Plants Need?">How Much Light Do Outdoor Marijuana Plants Need?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/black-widow-marijuana-strain-review-and-pictures" title="Black Widow Marijuana Strain Review And Pictures">Black Widow Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/what-is-marijuana-kief" title="What Is Marijuana Kief?">What Is Marijuana Kief?</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-much-dabs-can-you-make-from-one-pound-of-marijuana" title="How Much Dabs Can You Make with Marijuana?">How Much Dabs Can You Make with Marijuana?</a> <br> <a href="https://theweedblog.com/growing/how-to-prune-your-marijuana-plants-to-grow-huge-buds" title="How To Prune Your Marijuana Plants To Grow Huge Buds">How To Prune Your Marijuana Plants To Grow Huge Buds</a> <br> <a href="https://theweedblog.com/growing/powdery-mildew-a-grower-s-perspective-on-recovery-and-prevention" title="Powdery Mildew: A Growerâ€™s Perspective on Recovery and Prevention">Powdery Mildew: A Growerâ€™s Perspective on Recovery and Prevention</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-no-bake-chocolate-marijuana-cookies" title="How To Make No-Bake Chocolate Marijuana Cookies">How To Make No-Bake Chocolate Marijuana Cookies</a> <br> <a href="https://theweedblog.com/growing/grow-gigantic-marijuana-buds" title="How To Grow Gigantic Marijuana Buds - The Weed Blog">How To Grow Gigantic Marijuana Buds - The Weed Blog</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/purple-zombie-marijuana-strain-review-and-pictures" title="Purple Zombie Marijuana Strain Review And Pictures">Purple Zombie Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/when-and-how-to-water-marijuana-plants" title="When And How To Water Marijuana Plants">When And How To Water Marijuana Plants</a> <br> <a href="https://theweedblog.com/opinion/how-often-should-i-change-my-bong-water" title="How Often Should I Change My Bong Water?">How Often Should I Change My Bong Water?</a> <br> <a href="https://theweedblog.com/industry/7-new-pre-rolled-cones-help-your-pre-rolls-stand-out" title="7 New Types of Pre-rolled Cones that Help Your Pre-rolls Stand Out">7 New Types of Pre-rolled Cones that Help Your Pre-rolls Stand Out</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/tips-for-consuming-marijuana-in-your-dorm-room" title="Tips for Consuming Marijuana in Your Dorm Room">Tips for Consuming Marijuana in Your Dorm Room</a> <br> <a href="https://theweedblog.com/growing/how-to-get-rid-of-algae-in-marijuana-hydroponic-systems" title="How To Get Rid Of Algae In Marijuana Hydroponic Systems">How To Get Rid Of Algae In Marijuana Hydroponic Systems</a> <br> <a href="https://theweedblog.com/culture/5-essential-health-tips-for-cannabis-consumers" title="5 Essential Health Tips for Cannabis Consumers">5 Essential Health Tips for Cannabis Consumers</a> <br> <a href="https://theweedblog.com/growing/spider-mites-marijuana-plants" title="Spider Mites and Marijuana Plants">Spider Mites and Marijuana Plants</a> <br> <a href="https://theweedblog.com/opinion/10-ways-to-identify-a-stoner" title="10 Ways To Identify A Stoner">10 Ways To Identify A Stoner</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-many-joints-are-in-an-ounce-of-marijuana" title="How Many Joints Are In An Ounce Of Marijuana?">How Many Joints Are In An Ounce Of Marijuana?</a> <br> <a href="https://theweedblog.com/culture/marijuana-slang-terms" title="Marijuana Slang Terms: A Complete List - The Weed Blog">Marijuana Slang Terms: A Complete List - The Weed Blog</a> <br> <a href="https://theweedblog.com/science/live-rosin-v-live-resin" title="Live Rosin v. Live Resin">Live Rosin v. Live Resin</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/the-difference-between-indica-and-sativa-marijuana-plants" title="What Is The Difference Between Indica and Sativa?">What Is The Difference Between Indica and Sativa?</a> <br> <a href="https://theweedblog.com/industry/tips-for-opening-a-medical-marijuana-dispensary-in-texas" title="Tips for Opening a Medical Marijuana Dispensary in Texas">Tips for Opening a Medical Marijuana Dispensary in Texas</a> <br> <a href="https://theweedblog.com/growing/monster-cropping-marijuana-plants" title="Monster Cropping Marijuana Plants">Monster Cropping Marijuana Plants</a> <br> <a href="https://theweedblog.com/growing/what-is-the-sea-of-green-marijuana-growing-method" title="What Is The 'Sea Of Green' Marijuana Growing Method?">What Is The 'Sea Of Green' Marijuana Growing Method?</a> <br> <a href="https://theweedblog.com/growing/what-is-a-good-marijuana-grow-schedule-from-week-to-week" title="Marijuana Grow Schedule Example From Week To Week - The Weed Blog">Marijuana Grow Schedule Example From Week To Week - The Weed Blog</a> <br> <a href="https://theweedblog.com/growing/scrogging-for-beginners" title="Scrogging For Beginners">Scrogging For Beginners</a> <br> <a href="https://theweedblog.com/science/should-you-float-in-a-sensory-deprivation-tank-while-high" title="Should you Float in a Sensory Deprivation Tank While High?">Should you Float in a Sensory Deprivation Tank While High?</a> <br> <a href="https://theweedblog.com/culture/how-cannabis-affects-your-strength-and-muscle-building-potential" title="How Cannabis Affects Your Strength and Muscle-Building Potential">How Cannabis Affects Your Strength and Muscle-Building Potential</a> <br> <a href="https://theweedblog.com/ending-marijuana-prohibition/can-you-have-a-cdl-and-a-medical-marijuana-card" title="Can You Have a CDL and a Medical Marijuana Card">Can You Have a CDL and a Medical Marijuana Card</a> <br> <a href="https://theweedblog.com/guides/how-to-clean-your-pipe-or-bong" title="How to Clean a Pipe/Bowl | Best Way to Clean a Bong | How to Clean a Water Pipe">How to Clean a Pipe/Bowl | Best Way to Clean a Bong | How to Clean a Water Pipe</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-get-stuck-kief-out-of-a-marijuana-grinder" title="How To Get Stuck Kief Out Of A Marijuana Grinder">How To Get Stuck Kief Out Of A Marijuana Grinder</a> <br> <a href="https://theweedblog.com/medical-marijuana-policy/growing-medical-marijuana-near-a-school-zone" title="Growing Medical Marijuana Near A School Zone">Growing Medical Marijuana Near A School Zone</a> <br> <a href="https://theweedblog.com/growing/the-top-8-marijuana-strains-in-2018" title="The Top 8 Marijuana Strains in 2018">The Top 8 Marijuana Strains in 2018</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/white-diamonds-marijuana-strain-review" title="White Diamonds Marijuana Strain Review">White Diamonds Marijuana Strain Review</a> <br> <a href="https://theweedblog.com/marijuana-science/how-long-does-marijuana-stay-in-your-system-infographic" title="Urine Drug Test To Find Marijuana In Your System - The Weed Blog">Urine Drug Test To Find Marijuana In Your System - The Weed Blog</a> <br> <a href="https://theweedblog.com/growing/how-often-should-i-water-my-marijuana-plants" title="Marijuana Plants And How Oftern You Should Water? - The Weed Blog">Marijuana Plants And How Oftern You Should Water? - The Weed Blog</a> <br> <a href="https://theweedblog.com/growing/what-is-the-ideal-temperature-for-growing-marijuana-plants" title="What Is The Ideal Temperature For Growing Marijuana Plants?">What Is The Ideal Temperature For Growing Marijuana Plants?</a> <br> <a href="https://theweedblog.com/growing/optimal-grow-room-humidity-at-every-stage-of-your-cannabis-grow" title="Optimal Grow Room Humidity at Every Stage of your Cannabis Grow">Optimal Grow Room Humidity at Every Stage of your Cannabis Grow</a> <br> <a href="https://theweedblog.com/cooking/how-to-make-cannabis-infused-nut-butter" title="How to Make Cannabis-Infused Nut Butter">How to Make Cannabis-Infused Nut Butter</a> <br> <a href="https://theweedblog.com/culture/upgrade-your-cannabis-vape-pen-with-ooze" title="Ooze Pen Review: A Slim Vape Pen for Dabbing on the Go | Using the Ooze Dab Pen">Ooze Pen Review: A Slim Vape Pen for Dabbing on the Go | Using the Ooze Dab Pen</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/the-best-way-to-add-moisture-to-over-dry-marijuana" title="The Best Way to Add Moisture to Over-Dry Marijuana">The Best Way to Add Moisture to Over-Dry Marijuana</a> <br> <a href="https://theweedblog.com/marijuana-science/how-much-marijuana-does-it-take-for-someone-to-overdose" title="How Much Marijuana Does It Take For Someone To Overdose?">How Much Marijuana Does It Take For Someone To Overdose?</a> <br> <a href="https://theweedblog.com/opinion/how-to-tell-if-marijuana-dabs-are-good-or-bad" title="How To Tell If Marijuana Dabs Are Good Or Bad">How To Tell If Marijuana Dabs Are Good Or Bad</a> <br> <a href="https://theweedblog.com/guides/what-is-a-marijuana-eighth-18" title="How Much Is an Eighth of Weed in Grams? | Whatâ€™s an Eighth of Weed? | Marijuana Facts for Newbies">How Much Is an Eighth of Weed in Grams? | Whatâ€™s an Eighth of Weed? | Marijuana Facts for Newbies</a> <br> </span></p></div><span style="color: #444;">•</span><div class="nav-category inline"> <input type="checkbox" class="read-more-state" id="collapse-cat-2"> <label for="collapse-cat-2" class="read-more-trigger">Culture &amp; Advocacy</label><p class="read-more-wrap"> <span class="read-more-target"> <a href="https://theweedblog.com/culture/some-of-the-best-dab-pens-of-2018" title="Some of the Best Dab Pens of 2018">Some of the Best Dab Pens of 2018</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/purple-diesel-marijuana-strain-review-and-pictures" title="Purple Diesel Marijuana Strain Review And Pictures">Purple Diesel Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/dank-marijuana-strain-and-edible-review-number-eleven" title="Dank Marijuana Strain And Edible Review Number Eleven">Dank Marijuana Strain And Edible Review Number Eleven</a> <br> <a href="https://theweedblog.com/growing/how-important-is-oxygen-for-marijuana-plants" title="How Important Is Oxygen For Marijuana Plants?">How Important Is Oxygen For Marijuana Plants?</a> <br> <a href="https://theweedblog.com/medical/how-does-cbd-treat-anxiety" title="How Does CBD Effectively Treat Anxiety?">How Does CBD Effectively Treat Anxiety?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/white-widow-marijuana-strain-review-and-pictures" title="White Widow Marijuana Strain Review And Pictures">White Widow Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/cinderella-marijuana-strain-review-and-pictures" title="Cinderella Marijuana Strain Review And Pictures">Cinderella Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/guest-post/why-is-alcohol-legal-but-not-marijuana" title="Why Is Alcohol Legal But Not Marijuana?">Why Is Alcohol Legal But Not Marijuana?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/king-kush-marijuana-strain-review-and-pictures" title="King Kush Marijuana Strain Review And Pictures">King Kush Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/policies/history-marijuana-use-throughout-time" title="The History of Marijuana Use">The History of Marijuana Use</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/critical-mass-marijuana-strain-review-and-pictures" title="Critical Mass Marijuana Strain Review And Pictures">Critical Mass Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/industry/cannabis-industry-who-s-who-meet-cannabis-training-university-ceo-jeffrey-zorn" title="Cannabis Industry Whoâ€™s Who: Meet Cannabis Training University CEO Jeffrey Zorn">Cannabis Industry Whoâ€™s Who: Meet Cannabis Training University CEO Jeffrey Zorn</a> <br> <a href="https://theweedblog.com/ending-marijuana-prohibition/how-do-cops-determine-the-street-value-of-marijuana" title="How Do Cops Determine The Street Value Of Marijuana?">How Do Cops Determine The Street Value Of Marijuana?</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/what-is-a-waterfall-marijuana-bong" title="What Is A Waterfall Marijuana Bong?">What Is A Waterfall Marijuana Bong?</a> <br> <a href="https://theweedblog.com/growing/how-to-get-rid-of-spider-mites-on-marijuana-plants" title="How To Get Rid Of Spider Mites On Marijuana Plants">How To Get Rid Of Spider Mites On Marijuana Plants</a> <br> <a href="https://theweedblog.com/culture/3-ways-weed-can-boost-your-love-life" title="3 Ways Weed Can Boost Your Love Life">3 Ways Weed Can Boost Your Love Life</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/big-bang-marijuana-strain-review" title="Big Bang Marijuana Strain Review">Big Bang Marijuana Strain Review</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/fire-og-marijuana-strain-review-and-pictures" title="Fire OG Marijuana Strain Review And Pictures">Fire OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/does-marijuana-increase-the-female-libido" title="Does Marijuana Increase The Female Libido?">Does Marijuana Increase The Female Libido?</a> <br> <a href="https://theweedblog.com/hemp-info/how-to-make-hemp-seed-coffee" title="How To Make Hemp Seed Coffee">How To Make Hemp Seed Coffee</a> <br> <a href="https://theweedblog.com/growing/dont-let-cats-and-dogs-around-your-marijuana-garden" title="Don't Let Cats And Dogs Around Your Marijuana Garden">Don't Let Cats And Dogs Around Your Marijuana Garden</a> <br> <a href="https://theweedblog.com/growing/growing-marijuana-soil-versus-hydroponics" title="Growing Marijuana - Soil Versus Hydroponics">Growing Marijuana - Soil Versus Hydroponics</a> <br> <a href="https://theweedblog.com/culture/stoner-movie-review-half-baked" title="Stoner Movie Review â€” Half Baked">Stoner Movie Review â€” Half Baked</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/afghan-kush-marijuana-strain-review-and-pictures" title="Afghan Kush Marijuana Strain Review And Pictures">Afghan Kush Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/where-are-the-best-places-to-grow-marijuana-outdoors" title="Where Are The Best Places To Grow Marijuana Outdoors?">Where Are The Best Places To Grow Marijuana Outdoors?</a> <br> <a href="https://theweedblog.com/medical/autism-qualifying-condition-medical-marijuana" title="Autism Should be a Qualifying Condition for Medical Marijuana">Autism Should be a Qualifying Condition for Medical Marijuana</a> <br> <a href="https://theweedblog.com/culture/recreational-sales-soar-sesh-buses-illinois" title="Recreational Sales Soar and Sesh Buses Hit the Streets in Illinois">Recreational Sales Soar and Sesh Buses Hit the Streets in Illinois</a> <br> <a href="https://theweedblog.com/advocacy/elizabeth-warren-plan-marijuana-legalization" title="Elizabeth Warren Unveils Her Plan for Marijuana Legalization">Elizabeth Warren Unveils Her Plan for Marijuana Legalization</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/what-do-you-do-with-your-marijuana-shake" title="What Do You Do With Your Marijuana 'Shake?'">What Do You Do With Your Marijuana 'Shake?'</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/blue-dragon-marijuana-strain-review-and-pictures" title="Blue Dragon Marijuana Strain Review And Pictures">Blue Dragon Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/culture/sharpstone-grinders" title="SharpStone Grinders">SharpStone Grinders</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-roll-a-joint-with-a-crutch" title="How To Roll A Joint With A Crutch">How To Roll A Joint With A Crutch</a> <br> <a href="https://theweedblog.com/culture/product-review-novex-ooze" title="Product Review: The Novex by Ooze">Product Review: The Novex by Ooze</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/maui-wowie-marijuana-strain-review-and-pictures" title="Maui Wowie Marijuana Strain Review And Pictures">Maui Wowie Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/culture/enjoy-galentine-s-day-with-lady-jays" title="Enjoy &quot;Galentine's&quot; Day with Lady Jays">Enjoy "Galentine's" Day with Lady Jays</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/orange-crush-marijuana-strain-review-and-pictures" title="Orange Crush Marijuana Strain Review And Pictures">Orange Crush Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/grapefruit-cannabis-strain-review-and-pictures" title="Grapefruit Cannabis Strain Review And Pictures">Grapefruit Cannabis Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/the-life-cycle-of-marijuana-plants" title="The Life Cycle Of Marijuana Plants">The Life Cycle Of Marijuana Plants</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/red-hair-mistress-marijuana-strain-review" title="Red Hair Mistress Marijuana Strain Review">Red Hair Mistress Marijuana Strain Review</a> <br> <a href="https://theweedblog.com/marijuana-products/marijuana-product-review-magical-butter-machine" title="Marijuana Product Review - Magical Butter Machine">Marijuana Product Review - Magical Butter Machine</a> <br> <a href="https://theweedblog.com/medical/exactly-how-does-marijuana-relieve-pain" title="Exactly How Does Marijuana Relieve Pain?">Exactly How Does Marijuana Relieve Pain?</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-make-marijuana-clones" title="How To Make Marijuana Clones">How To Make Marijuana Clones</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-roll-a-blunt" title="How To Roll A Blunt">How To Roll A Blunt</a> <br> <a href="https://theweedblog.com/industry/whoopi-maya-closing-cannabis-company" title="Whoopi &amp; Maya Parting Ways">Whoopi &amp; Maya Parting Ways</a> <br> <a href="https://theweedblog.com/marijuana-entertainment/christmas-songs-for-stoners" title="Christmas Songs For Stoners">Christmas Songs For Stoners</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-properly-clean-your-dab-rig" title="How To PROPERLY Clean Your Dab Rig">How To PROPERLY Clean Your Dab Rig</a> <br> <a href="https://theweedblog.com/policies/u-s-patent-6630507-schedule-one-contradiction" title="U.S Patent 6630507 and the Schedule-One Contradiction">U.S Patent 6630507 and the Schedule-One Contradiction</a> <br> <a href="https://theweedblog.com/smoking-pieces/fumed-glass-mini-mushroom-bong-with-color-cap" title="Fumed Glass Mini Mushroom Bong With Color Cap">Fumed Glass Mini Mushroom Bong With Color Cap</a> <br> <a href="https://theweedblog.com/smoking-pieces/black-six-person-hookah-bong" title="Black Six Person Hookah Bong">Black Six Person Hookah Bong</a> <br> <a href="https://theweedblog.com/culture/everything-that-you-need-to-know-about-the-new-marijuana-breathalyzer" title="Everything That You Need To Know About The New Marijuana Breathalyzer">Everything That You Need To Know About The New Marijuana Breathalyzer</a> <br> <a href="https://theweedblog.com/growing/trimming-tips-and-tricks-for-your-home-grow" title="Trimming Tips and Tricks for Your Home Grow">Trimming Tips and Tricks for Your Home Grow</a> <br> <a href="https://theweedblog.com/opinion/does-anyone-still-use-triple-beam-scales-to-weigh-marijuana" title="Does Anyone Still Use Triple Beam Scales To Weigh Marijuana?">Does Anyone Still Use Triple Beam Scales To Weigh Marijuana?</a> <br> <a href="https://theweedblog.com/growing/what-is-a-marijuana-plant" title="What Is A Marijuana Plant?">What Is A Marijuana Plant?</a> <br> <a href="https://theweedblog.com/marijuana-science/how-to-decarboxylate-cannabis" title="How to Decarboxylate Cannabis">How to Decarboxylate Cannabis</a> <br> <a href="https://theweedblog.com/growing/what-are-regular-feminized-and-auto-flowering-marijuana-seeds" title="What Are Regular">What Are Regular</a> <br> <a href="https://theweedblog.com/opinion/essay-on-why-cannabis-should-be-legalized" title="Essay on Why Cannabis Should be Legalized">Essay on Why Cannabis Should be Legalized</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/sharksbreath-marijuana-strain-review-and-pictures" title="Sharksbreath Marijuana Strain Review And Pictures">Sharksbreath Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/ending-marijuana-prohibition/can-your-car-run-on-hemp-fuel" title="Can Your Car Run On Hemp Fuel?">Can Your Car Run On Hemp Fuel?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/strawberry-satori-marijuana-strain-review-and-pictures" title="Strawberry Satori Marijuana Strain Review And Pictures">Strawberry Satori Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/whats-the-best-soil-for-growing-marijuana" title="What's The Best Soil For Growing Marijuana?">What's The Best Soil For Growing Marijuana?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/fruity-pebbles-marijuana-strain-review-and-pictures" title="Fruity Pebbles Marijuana Strain Review And Pictures">Fruity Pebbles Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/culture/helicopter-filming-spanish-bike-race-discovers-rooftop-pot-garden" title="Helicopter Filming Bike Race Discovers Pot Garden">Helicopter Filming Bike Race Discovers Pot Garden</a> <br> <a href="https://theweedblog.com/growing/can-stress-hermaphrodite-marijuana-plants" title="Can Stress Hermaphrodite Marijuana Plants?">Can Stress Hermaphrodite Marijuana Plants?</a> <br> <a href="https://theweedblog.com/culture/what-are-vape-pens-quick-guide" title="What are Vape Pens?">What are Vape Pens?</a> <br> <a href="https://theweedblog.com/culture/smoking-cannabis-edibles-coronavirus" title="Smoking Cannabis vs. Edibles in the Time of Coronavirus">Smoking Cannabis vs. Edibles in the Time of Coronavirus</a> <br> <a href="https://theweedblog.com/marijuana-science/how-many-different-cannabinoids-are-there-in-marijuana" title="How Many Different Cannabinoids Are There In Marijuana?">How Many Different Cannabinoids Are There In Marijuana?</a> <br> <a href="https://theweedblog.com/growing/how-to-grow-marijuana-hydroponically" title="How To Grow Marijuana Hydroponically">How To Grow Marijuana Hydroponically</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/big-buddha-cheese-marijuana-strain-review-and-pictures" title="Big Buddha Cheese Marijuana Strain Review And Pictures">Big Buddha Cheese Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/how-to-get-rid-of-cutworms-on-your-marijuana-plants" title="How To Get Rid Of Cutworms On Your Marijuana Plants">How To Get Rid Of Cutworms On Your Marijuana Plants</a> <br> <a href="https://theweedblog.com/growing/how-to-grow-the-og-kush-marijuana-strain-indoors" title="How To Grow The OG Kush Marijuana Strain Indoors">How To Grow The OG Kush Marijuana Strain Indoors</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-cannabis-cheesecake" title="How To Make Cannabis Cheesecake">How To Make Cannabis Cheesecake</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-marijuana-butter" title="How To Make Marijuana Butter">How To Make Marijuana Butter</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/blueberry-kush-marijuana-strain-review-and-pictures" title="Blueberry Kush Marijuana Strain Review And Pictures">Blueberry Kush Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-marijuana-oatmeal-cookies" title="How To Make Marijuana Oatmeal Cookies">How To Make Marijuana Oatmeal Cookies</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-easy-dank-marijuana-rice-crispy-treats" title="How To Make Marijuana Rice Crispy Treats">How To Make Marijuana Rice Crispy Treats</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/venom-og-marijuana-strain-review-and-pictures" title="Venom OG Marijuana Strain Review And Pictures">Venom OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/skywalker-marijuana-strain-review-and-pictures" title="Skywalker Marijuana Strain Review And Pictures">Skywalker Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/should-you-give-your-marijuana-plants-hard-or-soft-water" title="Should You Give Your Marijuana Plants Hard Or Soft Water?">Should You Give Your Marijuana Plants Hard Or Soft Water?</a> <br> <a href="https://theweedblog.com/industry/las-vegas-has-a-weed-drive-thru" title="Las Vegas Has a Weed Drive-Thru">Las Vegas Has a Weed Drive-Thru</a> <br> <a href="https://theweedblog.com/culture/south-parks-stance-cannabis-industry-culture" title="South Parkâ€™s Stance on the Cannabis Industry and Culture">South Parkâ€™s Stance on the Cannabis Industry and Culture</a> <br> <a href="https://theweedblog.com/content-partner/safer-brand-offers-organic-products-for-plants-and-the-planet" title="Safer Brand Offers Organic Products for Plants and the Planet">Safer Brand Offers Organic Products for Plants and the Planet</a> <br> <a href="https://theweedblog.com/growing/syncing-temperature-and-humidity-for-better-yields" title="Syncing Temperature and Humidity for Better Yields">Syncing Temperature and Humidity for Better Yields</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/woody-og-marijuana-strain-review-and-pictures" title="Woody OG Marijuana Strain Review And Pictures">Woody OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/bud-rot-marijuana-plants" title="Bud Rot and Your Marijuana Plants - The Weed Blog">Bud Rot and Your Marijuana Plants - The Weed Blog</a> <br> <a href="https://theweedblog.com/marijuana-pics/blackberry-skunk-marijuana-strain-pictures" title="BlackBerry Skunk Marijuana Strain Pictures">BlackBerry Skunk Marijuana Strain Pictures</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/the-importance-of-purging-your-dab-torch" title="The Importance Of Purging Your Dab Torch">The Importance Of Purging Your Dab Torch</a> <br> <a href="https://theweedblog.com/growing/measure-the-ph-and-tds-of-your-marijuana-garden-soil-regularly" title="The Importance of Measuring PH and TDS in your Cannabis Garden">The Importance of Measuring PH and TDS in your Cannabis Garden</a> <br> <a href="https://theweedblog.com/culture/see-how-one-company-is-using-terpenes-to-create-more-effective-edibles" title="See How One Company Is Using Terpenes To Create More Effective Edibles">See How One Company Is Using Terpenes To Create More Effective Edibles</a> <br> <a href="https://theweedblog.com/growing/the-best-soil-growing-marijuana" title="Marijuana Soil: What is the Best Soil for Growing? - The Weed Blog">Marijuana Soil: What is the Best Soil for Growing? - The Weed Blog</a> <br> <a href="https://theweedblog.com/marijuana-business-news/how-many-marijuana-strains-are-there" title="How Many Marijuana Strains Are There?">How Many Marijuana Strains Are There?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/butter-og-marijuana-strain-review-and-pictures" title="Butter OG Marijuana Strain Review And Pictures">Butter OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/a-simple-guide-to-breeding-your-cannabis-plants" title="A Simple Guide to Breeding your Cannabis Plants">A Simple Guide to Breeding your Cannabis Plants</a> <br> <a href="https://theweedblog.com/medical/marijuana-and-motivation-how-it-helps-to-overcome-depression" title="Marijuana and Depression: Is Marijuana Good for Depression? | The Best Weed for Depression">Marijuana and Depression: Is Marijuana Good for Depression? | The Best Weed for Depression</a> <br> <a href="https://theweedblog.com/cooking/how-to-make-marijuana-infused-olive-oil" title="How To Make Marijuana-Infused Olive Oil - The Weed Blog">How To Make Marijuana-Infused Olive Oil - The Weed Blog</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-make-dry-ice-hash" title="How To Make Dry Ice Hash">How To Make Dry Ice Hash</a> <br> <a href="https://theweedblog.com/culture/tips-to-cultivate-autoflowering-cannabis-seeds" title="Tips to Cultivate Autoflowering Cannabis Seeds">Tips to Cultivate Autoflowering Cannabis Seeds</a> <br> <a href="https://theweedblog.com/cooking/juicing-marijuana-for-health-reasons" title="Juicing Marijuana for Health Reasons">Juicing Marijuana for Health Reasons</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-roll-an-inside-out-blunt" title="How To Roll An Inside Out Blunt">How To Roll An Inside Out Blunt</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/black-mamba-marijuana-strain-review-and-pictures" title="Black Mamba Marijuana Strain Review And Pictures">Black Mamba Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/jack-herer-marijuana-strain-review-and-pictures" title="Jack Herer Marijuana Strain Review And Pictures">Jack Herer Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/five-places-to-hide-your-marijuana-stash" title="Five Places To Hide Your Marijuana Stash">Five Places To Hide Your Marijuana Stash</a> <br> <a href="https://theweedblog.com/ending-marijuana-prohibition/25-legal-drugs-more-dangerous-than-marijuana" title="25 Legal Drugs More Dangerous Than Marijuana">25 Legal Drugs More Dangerous Than Marijuana</a> <br> <a href="https://theweedblog.com/culture/concentrate-review-granddaddy-purple-cartridge-from-eden-extracts" title="Concentrate Review: Granddaddy Purple Cartridge from Eden Extracts">Concentrate Review: Granddaddy Purple Cartridge from Eden Extracts</a> <br> <a href="https://theweedblog.com/growing/how-to-get-rid-of-fungus-gnats-in-your-marijuana-garden" title="How To Get Rid Of Fungus Gnats In Your Marijuana Garden">How To Get Rid Of Fungus Gnats In Your Marijuana Garden</a> <br> <a href="https://theweedblog.com/guides/ounces-pound" title="How Many Ounces in a Pound of Weed? | How Much Is a Pound of Weed in Grams? | Weight of a Pound of Marijuana">How Many Ounces in a Pound of Weed? | How Much Is a Pound of Weed in Grams? | Weight of a Pound of Marijuana</a> <br> <a href="https://theweedblog.com/ending-marijuana-prohibition/do-utilities-tell-cops-about-marijuana-gardens-with-high-electricity-bills" title="Do Utilities Tell Cops About Marijuana Gardens With High Electricity Bills?">Do Utilities Tell Cops About Marijuana Gardens With High Electricity Bills?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/white-rhino-marijuana-strain-review-and-pictures" title="White Rhino Marijuana Strain Review And Pictures">White Rhino Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/opinion/who-s-the-biggest-stoner-in-the-world" title="Who Is The Biggest Stoner In The World?">Who Is The Biggest Stoner In The World?</a> <br> <a href="https://theweedblog.com/cooking/marijuana-recipes/how-to-make-marijuana-hot-chocolate" title="How To Make Marijuana Hot Chocolate">How To Make Marijuana Hot Chocolate</a> <br> <a href="https://theweedblog.com/growing/powdery-mildew-marijuana-plants" title="White Powdery Mildew And Your Marijuana Plants">White Powdery Mildew And Your Marijuana Plants</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/alien-bubba-marijuana-strain-review-and-pictures" title="Alien Bubba Marijuana Strain Review And Pictures">Alien Bubba Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/culture/can-medical-marijuana-help-with-alcohol-withdrawal" title="Can Medical Marijuana Help with Alcohol Withdrawal?">Can Medical Marijuana Help with Alcohol Withdrawal?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/girl-scout-cookies-marijuana-strain-review-and-pictures" title="Girl Scout Cookies Marijuana Strain Review And Pictures">Girl Scout Cookies Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/how-to-determine-the-size-of-your-marijuana-grow-room" title="How To Determine The Size Of Your Marijuana Grow Room">How To Determine The Size Of Your Marijuana Grow Room</a> <br> <a href="https://theweedblog.com/medical-marijuana-policy/how-much-thc-is-in-federal-medical-marijuana" title="How Much THC Is In Federal Medical Marijuana?">How Much THC Is In Federal Medical Marijuana?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/dank-marijuana-strain-and-edible-review" title="Dank Marijuana Strain and Edible Review">Dank Marijuana Strain and Edible Review</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/headband-marijuana-strain-review-and-pictures" title="Headband Marijuana Strain Review And Pictures">Headband Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/how-to-flower-cannabis-plants-with-led-grow-lights" title="How To Flower Cannabis Plants With LED Grow Lights">How To Flower Cannabis Plants With LED Grow Lights</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/purple-heart-marijuana-strain-review-and-pictures" title="Purple Heart Marijuana Strain Review And Pictures">Purple Heart Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/xxx-og-marijuana-strain-review-and-pictures" title="XXX OG Marijuana Strain Review And Pictures">XXX OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/how-and-when-to-transplant-your-marijuana-plants" title="How And When To Transplant Your Marijuana Plants?">How And When To Transplant Your Marijuana Plants?</a> <br> <a href="https://theweedblog.com/opinion/how-much-should-a-twenty-sack-or-dub-weigh" title="How Many Grams Is a Dub of Weed? | Weight of a 20 Sack of Weed | Marijuana News and Facts">How Many Grams Is a Dub of Weed? | Weight of a 20 Sack of Weed | Marijuana News and Facts</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/diablo-og-marijuana-strain-review-and-pictures" title="Diablo OG Marijuana Strain Review And Pictures">Diablo OG Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/industry/what-the-major-cannabis-vape-pen-manufacturers-are-doing-today" title="What The Major Cannabis Vape Pen Manufacturers Are Doing Today">What The Major Cannabis Vape Pen Manufacturers Are Doing Today</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/exodus-marijuana-strain-review" title="Exodus Marijuana Strain Review">Exodus Marijuana Strain Review</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-be-a-productive-pothead" title="How To Be A Productive Pothead">How To Be A Productive Pothead</a> <br> <a href="https://theweedblog.com/growing/the-best-way-to-add-moisture-to-over-dry-marijuana" title="The Best Way to Add Moisture to Over-Dry Marijuana">The Best Way to Add Moisture to Over-Dry Marijuana</a> <br> <a href="https://theweedblog.com/cooking/how-to-make-a-cannabis-infused-oreo-milkshake" title="How to Make a Cannabis Infused Oreo Milkshake">How to Make a Cannabis Infused Oreo Milkshake</a> <br> <a href="https://theweedblog.com/medical-marijuana-policy/does-smoking-marijuana-concentrates-increase-your-tolerance-level" title="Does Smoking Marijuana Concentrates Increase Your Tolerance Level?">Does Smoking Marijuana Concentrates Increase Your Tolerance Level?</a> <br> <a href="https://theweedblog.com/growing/will-deer-eat-my-outdoor-marijuana-plants" title="Will Deer Eat My Outdoor Marijuana Plants?">Will Deer Eat My Outdoor Marijuana Plants?</a> <br> <a href="https://theweedblog.com/growing/which-is-better-indoor-marijuana-or-outdoor-marijuana" title="Which Is Better: Indoor or Outdoor Marijuana? - The Weed Blog">Which Is Better: Indoor or Outdoor Marijuana? - The Weed Blog</a> <br> <a href="https://theweedblog.com/medical/the-5-top-cannabis-strains-for-diabetes" title="The 5 Top Cannabis Strains for Diabetes">The 5 Top Cannabis Strains for Diabetes</a> <br> <a href="https://theweedblog.com/medical/trumps-2021-budget-targets-states-rights-ending-mmj-protections" title="Trumpâ€™s 2021 Budget Targets Statesâ€™ Rights and Ending MMJ Protections">Trumpâ€™s 2021 Budget Targets Statesâ€™ Rights and Ending MMJ Protections</a> <br> <a href="https://theweedblog.com/marijuana-science/how-to-add-moisture-to-over-dried-marijuana" title="How To Add Moisture To Over Dried Marijuana">How To Add Moisture To Over Dried Marijuana</a> <br> <a href="https://theweedblog.com/growing/growing-marijuana-indoors-a-beginners-guide" title="Growing Marijuana Indoors: A Beginners Guide">Growing Marijuana Indoors: A Beginners Guide</a> <br> <a href="https://theweedblog.com/marijuana-science/how-to-pass-a-drug-test-for-marijuana" title="How to Pass a Drug Test for Marijuana - The Weed Blog">How to Pass a Drug Test for Marijuana - The Weed Blog</a> <br> <a href="https://theweedblog.com/culture/the-top-4-pre-roll-packs-for-oregon-summer" title="The Top 4 Pre Roll Packs for Oregon Summer">The Top 4 Pre Roll Packs for Oregon Summer</a> <br> <a href="https://theweedblog.com/ending-marijuana-prohibition/how-to-be-a-marijuana-dealer-starting-up" title="How to Sell Weed: Tips for How to Start Selling Weed and Make a Profit | How to Make Money Selling Weed">How to Sell Weed: Tips for How to Start Selling Weed and Make a Profit | How to Make Money Selling Weed</a> <br> <a href="https://theweedblog.com/medical/ohio-medical-marijuana-purchasing-limits" title="Ohio Changes Medical Marijuana Purchasing Limits">Ohio Changes Medical Marijuana Purchasing Limits</a> <br> <a href="https://theweedblog.com/growing/seven-ways-to-keep-pests-off-marijuana-plants" title="Seven Ways To Keep Pests Off Marijuana Plants">Seven Ways To Keep Pests Off Marijuana Plants</a> <br> <a href="https://theweedblog.com/marijuana-science/what-is-the-difference-between-thc-and-cbd" title="What Is The Difference Between THC And CBD?">What Is The Difference Between THC And CBD?</a> <br> <a href="https://theweedblog.com/growing/how-to-avoid-airy-and-loose-marijuana-buds-on-your-plants" title="How To Avoid Airy And Loose Marijuana Buds On Your Plants">How To Avoid Airy And Loose Marijuana Buds On Your Plants</a> <br> <a href="https://theweedblog.com/growing/cannabis-and-humidity-101-the-fundamentals-of-grow-room-humidity-control" title="Cannabis and Humidity 101: the Fundamentals of Grow Room Humidity Control">Cannabis and Humidity 101: the Fundamentals of Grow Room Humidity Control</a> <br> <a href="https://theweedblog.com/growing/how-to-grow-super-skunk-indoors" title="How To Grow Super Skunk Indoors">How To Grow Super Skunk Indoors</a> <br> <a href="https://theweedblog.com/growing/the-difference-between-indica-and-sativa-marijuana-plants" title="What Is The Difference Between Indica and Sativa?">What Is The Difference Between Indica and Sativa?</a> <br> <a href="https://theweedblog.com/growing/how-to-speed-up-the-marijuana-plant-flowering-process" title="How To Speed Up The Marijuana Plant Flowering Process">How To Speed Up The Marijuana Plant Flowering Process</a> <br> <a href="https://theweedblog.com/marijuana-pics/laffy-taffy-marijuana-strain-pictures" title="Laffy Taffy Marijuana Strain Pictures">Laffy Taffy Marijuana Strain Pictures</a> <br> <a href="https://theweedblog.com/growing/topping-marijuana-plants-can-increase-your-yield" title="Topping Marijuana Plants Can Increase Your Yield">Topping Marijuana Plants Can Increase Your Yield</a> <br> <a href="https://theweedblog.com/growing/choosing-fertilizer-marijuana-plants" title="Choosing Fertilizer for your Marijuana Plants - The Weed Blog">Choosing Fertilizer for your Marijuana Plants - The Weed Blog</a> <br> <a href="https://theweedblog.com/marijuana-products/ac-greebs-smoking-steel-is-a-must-for-gravity-bong-hits" title="AC Greebs Smoking Steel Is A Must For Gravity Bong Hits">AC Greebs Smoking Steel Is A Must For Gravity Bong Hits</a> <br> <a href="https://theweedblog.com/growing/how-to-unlock-99-of-the-thc-and-cbd-power-in-your-cannabis" title="How to Unlock 99% of the THC and CBD Power in Your Cannabis">How to Unlock 99% of the THC and CBD Power in Your Cannabis</a> <br> <a href="https://theweedblog.com/growing/when-do-marijuana-plants-start-to-flower" title="Flowering - When Do Marijuana Plants Begin - The Weed Blog">Flowering - When Do Marijuana Plants Begin - The Weed Blog</a> <br> <a href="https://theweedblog.com/culture/product-review-the-slim-twist-pro-by-ooze" title="Slim Twist Pro by Ooze Review">Slim Twist Pro by Ooze Review</a> <br> <a href="https://theweedblog.com/medical-marijuana-policy/does-cannabis-help-treat-gastritis" title="Does Cannabis Help Treat Gastritis?">Does Cannabis Help Treat Gastritis?</a> <br> <a href="https://theweedblog.com/marijuana-science/does-marijuana-have-any-affect-on-hormone-based-birth-control" title="Does Marijuana Have Any Affect On Hormone Based Birth Control?">Does Marijuana Have Any Affect On Hormone Based Birth Control?</a> <br> <a href="https://theweedblog.com/growing/what-is-the-best-temperature-for-a-marijuana-grow-room" title="What Is The Best Temperature For A Marijuana Grow Room?">What Is The Best Temperature For A Marijuana Grow Room?</a> <br> <a href="https://theweedblog.com/growing/what-do-marijuana-plants-eat" title="What Do Marijuana Plants Eat?">What Do Marijuana Plants Eat?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/how-can-you-tell-if-marijuana-is-indica-or-sativa" title="How Can You Tell If Marijuana Is Indica or Sativa">How Can You Tell If Marijuana Is Indica or Sativa</a> <br> <a href="https://theweedblog.com/growing/how-to-get-your-marijuana-clones-to-root-faster" title="How To Get Your Marijuana Clones To Root Faster">How To Get Your Marijuana Clones To Root Faster</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/platinum-jack-marijuana-strain-review-and-pictures" title="Platinum Jack Marijuana Strain Review And Pictures">Platinum Jack Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/cooking/how-to-make-marijuana-brownies" title="How To Make The Perfect Marijuana Brownies">How To Make The Perfect Marijuana Brownies</a> <br> <a href="https://theweedblog.com/growing/how-to-kill-spider-mites-on-your-marijuana-plants" title="Spider Mites On Your Marijuana Plants - How Do you Kill Them?">Spider Mites On Your Marijuana Plants - How Do you Kill Them?</a> <br> <a href="https://theweedblog.com/marijuana-strain-reviews/animal-cookies-marijuana-strain-review-and-pictures" title="Animal Cookies Marijuana Strain Review And Pictures">Animal Cookies Marijuana Strain Review And Pictures</a> <br> <a href="https://theweedblog.com/growing/secrets-of-colorful-cannabis-how-to-grow-purple-cannabis-buds" title="The Secrets of Colorful Cannabis: How To Grow Purple Cannabis Buds">The Secrets of Colorful Cannabis: How To Grow Purple Cannabis Buds</a> <br> <a href="https://theweedblog.com/growing/the-importance-of-nitrogen-for-marijuana-plants" title="The Importance Of Nitrogen For Marijuana Plants">The Importance Of Nitrogen For Marijuana Plants</a> <br> <a href="https://theweedblog.com/growing/what-is-the-right-humidity-level-for-marijuana-plants" title="What Is The Right Humidity Level For Marijuana Plants?">What Is The Right Humidity Level For Marijuana Plants?</a> <br> <a href="https://theweedblog.com/culture/edible-review-wana-brands-watermelon-sour-sativa-gummies" title="Edible Review: Wana Brands Watermelon Sour Sativa Gummies">Edible Review: Wana Brands Watermelon Sour Sativa Gummies</a> <br> <a href="https://theweedblog.com/cannabis-tips-and-tricks/how-to-bake-your-vaporizer-remains" title="How To Bake Your Vaporizer Remains">How To Bake Your Vaporizer Remains</a> <br> <a href="https://theweedblog.com/growing/when-is-best-time-of-year-grow-cannabis-in-your-yard" title="When Is the Best Time of Year to Grow Cannabis in Your Yard?">When Is the Best Time of Year to Grow Cannabis in Your Yard?</a> <br> <a href="https://theweedblog.com/medical/how-medical-marijuana-can-help-with-blood-clotting-disorders" title="How Medical Marijuana Can Help With Blood Clotting Disorders">How Medical Marijuana Can Help With Blood Clotting Disorders</a> <br> <a href="https://theweedblog.com/culture/how-to-make-your-own-vape-pen-juice" title="Vape Pen Juice: How to Make Your Own? - The Weed Blog">Vape Pen Juice: How to Make Your Own? - The Weed Blog</a> <br> <a href="https://theweedblog.com/growing/how-to-control-powdery-mildew-on-your-marijuana-plants" title="Mildew on Marijuana Plants &amp; How to Control It - The Weed Blog">Mildew on Marijuana Plants &amp; How to Control It - The Weed Blog</a> <br> <a href="https://theweedblog.com/drug-testing/how-to-pass-a-hair-follicle-drug-test-for-marijuana" title="Hair Follicle Drug Test - Pass a Drug Test For Marijuana - The Weed Blog">Hair Follicle Drug Test - Pass a Drug Test For Marijuana - The Weed Blog</a> <br> <a href="https://theweedblog.com/growing/temperature-problems-and-marijuana-plants" title="Temperature Problems And Marijuana Plants">Temperature Problems And Marijuana Plants</a> <br> <a href="https://theweedblog.com/drug-testing/can-someone-fail-a-drug-test-for-simply-touching-marijuana" title="Can Someone Fail A Drug Test For Simply Touching Marijuana?">Can Someone Fail A Drug Test For Simply Touching Marijuana?</a> <br> <a href="https://theweedblog.com/culture/15-ultimate-munchie-foods-for-stoners" title="15 Ultimate Munchie Foods for Stoners">15 Ultimate Munchie Foods for Stoners</a> <br> <a href="https://theweedblog.com/growing/how-to-prune-marijuana-plants-seven-tips" title="How To Prune Marijuana Plants - Seven Tips - The Weed Blog">How To Prune Marijuana Plants - Seven Tips - The Weed Blog</a> <br> </span></p></div></div></div></div></div></div></div></div></section></div></div></div> <script type='text/javascript'>var countVars = {"disqusShortname":"theweedblog"};
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"60504 https:\/\/theweedblog.com\/?p=60504","disqusShortname":"theweedblog","disqusTitle":"Alabama Authorities Sentence Black Disabled Veteran to Five Years for Medical Marijuana","disqusUrl":"https:\/\/theweedblog.com\/culture\/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana","postId":"60504"};
var dclCustomVars = {"dcl_progress_text":"Loading..."};
var countVars = {"disqusShortname":"theweedblog"};
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"60504 https:\/\/theweedblog.com\/?p=60504","disqusShortname":"theweedblog","disqusTitle":"Alabama Authorities Sentence Black Disabled Veteran to Five Years for Medical Marijuana","disqusUrl":"https:\/\/theweedblog.com\/culture\/alabama-authorities-sentence-black-disabled-veteran-five-years-medical-marijuana","postId":"60504"};
var dclCustomVars = {"dcl_progress_text":"Loading..."};</script> <script type='text/javascript' src='https://theweedblog-com.exactdn.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript'>var aepc_pixel_events = {"custom_events":{"AdvancedEvents":[{"params":{"login_status":"not_logged_in","post_type":"post","object_id":60504,"object_type":"single","tax_category":["Culture"],"tax_yst_prominent_words":["alabama","eboni","iraq","legal","legal medical","legal medical marijuana","marijuana","medical","medical marijuana","military","mmj","sean","sean worsley","search","veteran","wife","wife eboni","worsley","worsley and his wife","worsley and his wife eboni"]},"delay":0}]}};</script> <script type='text/javascript'>var ElementorProFrontendConfig = {"ajaxurl":"https:\/\/theweedblog.com\/wp-admin\/admin-ajax.php","nonce":"b88a29b0d2","i18n":{"toc_no_headings_found":"No headings were found on this page."},"shareButtonsNetworks":{"facebook":{"title":"Facebook","has_counter":true},"twitter":{"title":"Twitter"},"google":{"title":"Google+","has_counter":true},"linkedin":{"title":"LinkedIn","has_counter":true},"pinterest":{"title":"Pinterest","has_counter":true},"reddit":{"title":"Reddit","has_counter":true},"vk":{"title":"VK","has_counter":true},"odnoklassniki":{"title":"OK","has_counter":true},"tumblr":{"title":"Tumblr"},"delicious":{"title":"Delicious"},"digg":{"title":"Digg"},"skype":{"title":"Skype"},"stumbleupon":{"title":"StumbleUpon","has_counter":true},"mix":{"title":"Mix"},"telegram":{"title":"Telegram"},"pocket":{"title":"Pocket","has_counter":true},"xing":{"title":"XING","has_counter":true},"whatsapp":{"title":"WhatsApp"},"email":{"title":"Email"},"print":{"title":"Print"}},"facebook_sdk":{"lang":"en_US","app_id":""},"lottie":{"defaultAnimationUrl":"https:\/\/theweedblog.com\/wp-content\/plugins\/elementor-pro\/modules\/lottie\/assets\/animations\/default.json"}};</script> <script type='text/javascript'>var elementorFrontendConfig = {"environmentMode":{"edit":false,"wpPreview":false},"i18n":{"shareOnFacebook":"Share on Facebook","shareOnTwitter":"Share on Twitter","pinIt":"Pin it","downloadImage":"Download image"},"is_rtl":false,"breakpoints":{"xs":0,"sm":480,"md":768,"lg":1025,"xl":1440,"xxl":1600},"version":"2.9.13","urls":{"assets":"https:\/\/theweedblog.com\/wp-content\/plugins\/elementor\/assets\/"},"settings":{"page":[],"general":{"elementor_global_image_lightbox":"yes","elementor_lightbox_enable_counter":"yes","elementor_lightbox_enable_fullscreen":"yes","elementor_lightbox_enable_zoom":"yes","elementor_lightbox_enable_share":"yes","elementor_lightbox_title_src":"title","elementor_lightbox_description_src":"description"},"editorPreferences":[]},"post":{"id":60504,"title":"Black%20Disabled%20Veteran%20sentenced%20to%20Five%20Years%20for%20Medical%20Marijuana","excerpt":"","featuredImage":"https:\/\/theweedblog.com\/wp-content\/uploads\/prison-553836_1280.jpg"}};</script> <script defer src="https://theweedblog-com.exactdn.com/wp-content/cache/autoptimize/js/autoptimize_42bc947b3800c9efcd5a259128aea3ad.js"></script><script data-cfasync='false'>!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){function e(){t.media=a}var a=t.media||"all";t.addEventListener?t.addEventListener("load",e):t.attachEvent&&t.attachEvent("onload",e),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(e,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script></body></html>